Webmethods 10.7 installation error

Enter: [ F ] ?
APP_ERROR> WISSharedBundles: IPM>> FAILED Cannot Update Instance. REASON: Instance Management process finished with error code “1”. [EXPLANATION] CMD: /app/webmethoddev/profiles/SPM/…/…/IntegrationServer/instances/is_instance.sh “update” “-Dinstance.name=default” “-Dpackage.list=WmNUMDeployer,WmAssetPublisher,WmOptimize,WmAppPlat,WmDeployer,WmART,WmBrokerDeployer,WmCloudStreamsDeployer,WmTaskClient,WmMonitor,WmDB,WmMFT,WmAgileAppsDeployer,WmTN,WmTNExtDC” “-Dfeature.list=com.softwareag.mft,com.softwareag.mom.is.mft.webapp.feature,com.softwareag.mom.is.eda.feature,com.softwareag.mom.is.dev.feature”, OUTPUT: Buildfile: /app/webmethoddev/IntegrationServer/instances/is_instance.xml
APP_ERROR> Installer: Cannot install update(s). Finish installing your products, and then use Software AG Update Manager to install the update(s).
[SoftwareAGInstaller20210616-Linux_x86_64.bin] ERROR: Installation failed (1).
[SoftwareAGInstaller20210616-Linux_x86_64.bin] Please check the log and search for errors.
[SoftwareAGInstaller20210616-Linux_x86_64.bin] Correct the situation and try again.
[SoftwareAGInstaller20210616-Linux_x86_64.bin] Cleaning up /tmp/saginstaller.8080…

Hi Ishwar,

looks like Installer tries to apply product fixes before the base installation of the products were completed.

Are you running installer from command line or is this a command central based approach using templates?

Regards,
Holger

Using command line, any suggestions?

Also I notice WmMFT packages not installed, can we install this package separately ? I see MWS, IS and Mashzone is accessible.

Have already applied fixes but WmMFT package is missing after install.

Thanks,
-Ishwar Wagh

Hi Ihshwar,

see webMethods Installation Guide for infomations about using the Installer in command line mode.

Is the WmMFT missing completely, or is it just disabled?
Might be a license file issue.

Regards,
Holger

WmMFT is completely missing, any suggestion how to fix it?

Thanks,
-Ishwar Wagh

Please check your list of components in Empower as well as in the downloaded installation image if the MFT feature is available.

Might be that you are not licensed for MFT feature which is then not installed to the IS but fails when you try to apply a fix to it.

Can you describe step by step how you are trying to install/update the instance, please?

Regards,
Holger

I have done install with same image on QA servers and there I did not face any issues but in Dev I am facing issue with WmMFT, rest all working fine and accessible.

If you can help with fix on how to install WmMFT and my problem is solved.

Thanks
-Ishwar Wagh

Hi

I would suggest not choosing to install the update during installation,try to only install the products , check for any errors. Check if MFT is installed.
Then try the updates as a separate step. Please share any errors that you find.

Additionally , can you also share the logs as referred in the IS installation error (10.7) - Forum - webMethods - Software AG Tech Community & Forums ie, the logs located under IntegrationServer/instances/logs and install/logs directory?

-Nagendra

First, please ensure the MFT installer component (should show as Installed or greyed out) its successful and also check from the Admin console UI packages and determine the next steps closely and if required uninstall and re-install safely before applying running SUM tool.

I know you already installed the same in QA env with no hiccups, but it’s worth to go step by step what must have went wrong in the DEV install base aspects:)

GL,
RMG

Can you please provide logs located under IntegrationServer/instances/logs and install/logs directory?

Thanks,
-Kalpesh

Hello,

I think the process failed while installing fixes (update). Maybe you should check your product image !

BR
Ahmed

Hi Ishwar.

Did you tried installing the products first and then try to install the latest fixes if any.
Try to check the package in installed or not.