Workspace issue

Hi folks,

Installed some fixes for WM9.5 after that my workspace is not opening tried to switch it but the designer completely exits

designer is opening in a default workspace workspace95 but its not switching to my own workspace

Thanks Inadvance

Hi sai,

did you try to start the designer with “eclipse.exe -clean” from command prompt after applying the updates?

Is your own workspace still present where it should be?

Regards,
Holger

1 Like

Typically, the cause of the above Eclipse error is due to some corruption issue with the current workspace. To fix that problem, you can create a new workspace.

Use the Designer, File Menu → Switch Workspace → Other.

This launches the same workspace launcher with the option to copy settings.

Before you do it, first export your projects if you have any.
Then make the workspace change and import them.

Hi,

I have wM9.8, my designer is opening default workspace when I start it. I have tried above troubleshooting tips, no help. Any other in mind?

Now I’m opening required workspace after default workspace loaded with the option (File > swithch workspace…).

Hi Shravan,

when switching the Workspace (use “other workspace” option) check for the Checkboxes below the Workspace selector.

There should be one as “use as default” or similar.

See Working with Designer Help for further informations.

Regards,
Holger

Thank you Holger for quick response, tried as you suggested but not solved.

I have tried tricks from Eclipse forum (as Designer built on Eclipse), removing folder “.manager” from designer installed folder “…eclipse\configuration\org.eclipse.osgi” is worked. now I’m able to see workspace selector dialog box.

After workspace selection, I see folder “.manager” back in same location, but I don’t see my issue back. Could be because of some internal configuration files re-created.

ref: 409552 – [WorkbenchLauncher] Workspace prompt on startup in eclipse is not working