What is needed to install APP

Hi
What is needed to have the APP Platform on IS ?
I have an IS which seems does not have APP . So I intalled the package WmAppPlat
fbut I get still this error:
Project bundle generated!
Error installing project bundle in the repository! null
Designer is connected to the server over JMX as required; however,
the App Platform remote service is unavailable.
Verify the ‘Application Platform Support’ component is installed for this server.
java.lang.reflect.UndeclaredThrowableException

1 Like

To use App Platform on Integration Server, one must install a server and a Designer component.
Using the webMethods installer, you can select the following items from the installation menu tree.

1 - Under Integration Server, select ‘Application Platform’

2 - Under ‘Designer’, select ‘Application Platform’. ( In that submenu, you can de-select ‘Composite Applications Integration’ since that is used with the myWebMethods Server product.)

Hi Warren,
I assume this Designer component has to be installed only on Designer machine, not the IS machine. Right?

We have installed the IS component on IS and the Designer component on Designer, but still get the very same error message. Have you got any other ideas?

Best regards,
Marcus

PS:
AppPlatform-specific fixes installed on the IS (RHEL x64): PLS_IS_10.3.0_Fix1
AppPlatform-specific fixes installed on the Designer (Win10 x64): none

Hi Warren,
after reading your answer in the other thread, I noticed something interesting:
The JMX port configured via composite template for CommandCentral during installation is 8096, but the properties file of the IS profile says 8098 … don’t know why!?

When I switched to the 8098 port stated in the properties file, the connection could be established, but Designer reported another error upon trying to publish the App:

Funny thing is, that I do not connect to the IS as user Administrator, but with my AD user name … and that works with IS in all other cases (like login on IS Web Admin, service development in Designer, connection from Designer to IS server for Package Navigator, etc.). So, have you got any idea what could be the root cause of this error?

Many thanks in advance!
Marcus

Hi Marcus,

Your understanding is correct. Designer may be installed on a separate server and used to connect to App Platform / Integration Server installed in a different computer. It requires some additional configuration in this case.

  1. The App Platform bundles in Designer use a JMX connection to communicate with the remote server. By default, the port number will be 8075; however, the installer will change this if it detects that port is already opened. To confirm what was installed, review the contents of this file in your AP/Integration Server installation.

profiles/IS_default/configuration/com.softwareag.platform.config.propsloader/com.softwareag.jmx.connector.pid*.properties file.

Note, The Command Central composite template feature leverages installer modules, so you might see similar behavior if a designated port is in use.

  1. Designer’s ‘Service Development’ perspective configuration communicates to the IS primary port (e.g. 5555). App Platform uses the same credentials defined in Designer’s configuration under ‘/SoftwareAG/Integration Servers/’ (See ‘Window/Preferences’ menu path in Designer.)

That information is encrypted using Eclipse’s ‘secure storage’ feature. I’ve seen cases where this information gets corrupted. In that case, you can exit Designer, backup and delete the original storage files, and restart Designer. It will prompt you to specify a ‘hint’ and recreate the encrypted file. The storage files exist under ~/.eclipse/org.eclipse.equinox.security/. (Note, I’ve very rarlely encountered this problem on a Windows machine.)

When you delete the encrypted file, you will have to configure your Integration Server instances again under ‘/SoftwareAG/Integration Server/’ configuration path.

HTH

Hi Warren,
many thanks for you advice! I followed the procedure to recreate the secure storage of Designer, but to no avail. Is still get the same error message when trying to publish the App. I get the same error even if I actually use the Administrator credentials! Have you got any other idea?

Please note: All other connections to IS using the very same credentials are working.

Best regards,
Marcus

One more note:
I just tried to verify the AppPlatform installtion on IS according to the chapter “Verifying That Software AG Runtime Is Available” in the Application Platform User Guide. But I get HTTP error code 404 when I’m trying to call http://is-server:8072 or https://is-server:8074 even though I have checked the properties files of the IS profile whether these ports are actually being used.

Best regards,
Marcus

BTW: Why are these ports and their stati not listed on the IS Web Admin like all the other ports?

Marcus, 8072/4 are the default ports. I suspect your installation has chosen differrent ports. The port numbers used may be found in the …/profiles/IS_default/configuration/com.softwareag.platform.config.propsloader/com.softwareag.catalina.connector.http*.properties files.

You’ve mentioned composite templates. I suspect something is missing from your template definition. Are you able to install App Platform & IS using webMethods installer just to rule this out? ( Be sure to select ‘Application Platform’ under the Integration Server installer tree. If this works, you can send me the composite template you are using, and I will take a look.

-thanks

Hi Warren,
first of all, many thanks for your prompt responses!

I also thought so since another full webMethods installation (SPM+UM+MwS+IS) is running on the same machine, but under a different user. Hence, I had checked it ("… even though I have checked the properties files of the IS profile whether these ports are actually being used") just to find out that - allegedly - the ports have not been changed.
I’ve attached both properties files for you.

I’d also tried that in order to check whether it is actually installed. However, I cannot install it, because it is already installed.

Here’s the excerpt of the composite template which was used to configure IS’ JMX port and install AppPlatform component for IS:


templates:
  is-server:
    products:
      PLSCore:
      PLS_IS:
      integrationServer:
        SIT: 
          primary.port:    5555
          diagnostic.port: 9999
          jmx.port:        8096

Any other idea?

Best regards,
Marcus
com.softwareag.catalina.connector.http.pid-AppPlatform.properties (327 Bytes)
com.softwareag.catalina.connector.https.pid-AppPlatform.properties (618 Bytes)

Regarding the installed AppPlatform components, here’s a list of all installed PLS-related products provided by CommandCentral:
[PLSspm,PLSCore,PLS_IS,PLS_MWS]

Update:
I’ve changed both ports (HTTP and HTTPS) of the AppPlatform in the properties files and restarted IS, but to no avail. The error message in Designer is still the same and accessing both of the new ports in the browser results in 404 responses.

Note: I had to recover the backup of the secure storage of Eclipse since I was running into Eclipse bug 277820 (StorageException: Given final block not properly padded.) each time I restarted Eclipse or change any credentials.

Marcus,
edit profiles/IS_default/configuration/config.ini to add the following property.
osgi.console=8045
(Or pick a port that is not in use)

Having done this, please restart the IS profile.

Next, launch Designer and switch to the ‘Terminal’ view. ( Eclipse Window/Show View/ Terminal)
There, you can open a telnet terminal and telnet to this port (not telnet port) and server.
Having done so, you will get an prompt where you can enter the following commands

osgi> ss pls

This first command will show the bundle states for the AP bundles running in the server.

Here’s an example from 10.3.

osgi> ss pls
“Framework is launched.”

id State Bundle
27 ACTIVE com.softwareag.applatform.pls.bundle.config_10.3.0.0000-0207
28 ACTIVE com.softwareag.applatform.pls.bundle.deploy.service_10.3.0.0000-0207
29 ACTIVE com.softwareag.applatform.pls.bundle.deployer_10.3.0.0000-0207
30 ACTIVE com.softwareag.applatform.pls.bundle.repository.manager_10.3.0.0000-0207
31 ACTIVE com.softwareag.applatform.pls.codegen_10.3.0.0000-0207
32 ACTIVE com.softwareag.applatform.pls.commons_10.3.0.0001-0229
33 ACTIVE com.softwareag.applatform.pls.gateway.api_10.3.0.0000-0207
34 ACTIVE com.softwareag.applatform.pls.gateway.extender_10.3.0.0003-0235
35 ACTIVE com.softwareag.applatform.pls.gateway.impl_10.3.0.0003-0235
36 ACTIVE com.softwareag.applatform.pls.sdk.core_10.3.0.0001-0229
37 ACTIVE com.softwareag.applatform.pls.security_10.3.0.0000-0207
38 ACTIVE com.softwareag.applatform.pls.security.is_10.3.0.0003-0235
39 ACTIVE com.softwareag.applatform.pls.service.browser_10.3.0.0000-0207
40 ACTIVE com.softwareag.applatform.pls.service.codegen_10.3.0.0000-0207
41 ACTIVE com.softwareag.applatform.pls.service.executor_10.3.0.0003-0235
42 ACTIVE com.softwareag.applatform.pls.service.metadata_10.3.0.0000-0207
43 ACTIVE com.softwareag.applatform.pls.util_10.3.0.0000-0207
44 RESOLVED com.softwareag.applatform.pls.web.is_10.3.0.0003-0235
Master=247
45 ACTIVE com.softwareag.applatform.pls.wrapper_10.3.0.0003-0235
osgi>

All your bundles should be active except the ‘web.is’ fragment bundle. If any of your bundles are not active, please run
osgi> diag
This command will indicate why the bundle is not active.

Can you please send me this output?

-thanks

Hi Warren,
please find the output as follows:


osgi> ss pls
"Framework is launched."


id      State       Bundle
27      ACTIVE      com.softwareag.applatform.pls.bundle.config_10.3.0.0000-0207
28      ACTIVE      com.softwareag.applatform.pls.bundle.deploy.service_10.3.0.0000-0207
29      ACTIVE      com.softwareag.applatform.pls.bundle.deployer_10.3.0.0000-0207
30      ACTIVE      com.softwareag.applatform.pls.bundle.repository.manager_10.3.0.0000-0207
31      ACTIVE      com.softwareag.applatform.pls.codegen_10.3.0.0000-0207
32      ACTIVE      com.softwareag.applatform.pls.commons_10.3.0.0000-0207
33      ACTIVE      com.softwareag.applatform.pls.gateway.api_10.3.0.0000-0207
34      ACTIVE      com.softwareag.applatform.pls.gateway.extender_10.3.0.0001-0219
35      ACTIVE      com.softwareag.applatform.pls.gateway.impl_10.3.0.0000-0207
36      ACTIVE      com.softwareag.applatform.pls.sdk.core_10.3.0.0000-0207
37      ACTIVE      com.softwareag.applatform.pls.security_10.3.0.0000-0207
38      ACTIVE      com.softwareag.applatform.pls.security.is_10.3.0.0001-0219
39      ACTIVE      com.softwareag.applatform.pls.service.browser_10.3.0.0000-0207
40      ACTIVE      com.softwareag.applatform.pls.service.codegen_10.3.0.0000-0207
41      ACTIVE      com.softwareag.applatform.pls.service.executor_10.3.0.0001-0219
42      ACTIVE      com.softwareag.applatform.pls.service.metadata_10.3.0.0000-0207
43      ACTIVE      com.softwareag.applatform.pls.util_10.3.0.0000-0207
44      RESOLVED    com.softwareag.applatform.pls.web.is_10.3.0.0001-0219
                    Master=421
45      ACTIVE      com.softwareag.applatform.pls.wrapper_10.3.0.0001-0219

Seems everything but the web.is component is active as it should be. What shall we do next?

Best regards,
Marcus

PS: I know I repeat myself, but I really want to thank you for your quick and excellent support!

Hi Warren,
as the Empower portal is down at the moment, I’m posting my solution here:

After our support session yesterday, I noticed that Designer always connects to all IS servers, which are configured in the preferences, when publishing an app - not only the target IS.
So I …

  1. removed all other Integration Servers from the preferences,
  2. removed all other MwS/IS from the Server view on the AppPlatform perspective,
  3. restarted Designer,
  4. switched to the Service Development perspective to ensure Designer is connected to the target IS (otherwise, the first publishing run fails and no following run is started since Designer considers the package synchronized).

Et voila! Now it works.

It is still working after adding all the IS and MwS servers again to Designer - even when the credentials for one of the other servers are deliberately wrong. Hence, I cannot reproduce the issue anymore.

Thank you very much for your support! Your insights and hints helped me to get down to the root cause of the issue!

Best regards,
Marcus

My conclusion:
Since there were many servers set in my Designer, I reckon the credentials for at least one of them got corrupted. Hence, connecting to one of the other IS servers which used the username “Administrator” failed and as a result, publishing the app to the target IS was aborted. However, IHMO that should not happen since it affects a completely different IS. So I consider it a bug in Designer.

I found the root cause for this issue:
We had several different versions of Designer installed on the same computer and Eclipse’s default settings caused all those different versions to use the same secure storage for credentials ([USERPROFILE].eclipse\org.eclipse.equinox.security). Thus, we got this error message each time we opened another version of Designer.
The solution was – fortunately – quite simple:
Add the following setting to the [INSTALLDIR]\Designer\eclipse\eclipse.ini file:

-eclipse.keyring
configuration\secure_storage

This forces Eclipse to put the secure storage file into the [i][INSTALLDIR]\Designer\eclipse\configuration[/i] directory.

Best regards,
Marcus

Hi Marcus,

thanks for pointing this out.

I also came across this issue whilst trying to test Designer 10.5 Trial on the same box which also had a Designer 9.5 and Designer 9.12 installed.

Designer 9.5 and 9.12 can co-exist together on the same box without issues when using different workspaces.
I think that this was introduced with Designer 10.x, whose Eclipse base seems to use another cipher spec to encrypt the secure storage.

After the secure storage has been edited by Designer 10.5 the other installations are no longer able to decrypt the secure storage to retrieve the passwords.

Might be worth a feature request at Brainstorm to get this setting added by default.

Regards,
Holger