Adding MWS remote server to runtime Environment in Designer

Couldn’t locate MWS server in my Designer ( windows > showview > server ).
Can anyone help me adding mws server in my server tab.

Thanks in advance

Hi Rameezraja,

please provide some screenshots of the view just be sure we are talking about the same view.

In my Server view I have 2 MWS remote servers, one for localhost@8585 and one for my development environment.

When you right click on the background of the view there will be a context menu where it has an option “New” at the top.
From here you can define additional MWS remote instances.

For further informations see the “CAF and OpenCAF Development Help” guide.
There is a chapter about “Working with My webMethods Server”, which also describes how new servers can be added.


1 Like

Thanks for reply Holger
I have tried with new option. FYI my servers are on Virtual Machine and my designer on windows.
i have attached the screenshot.

The “Installation directory” option is only when you have SPM and MWS on your machine (i.e., installed on the same machine as your Designer).

If your Platform Manager (SPM) and MWS are installed on a local/remote VM, you will have to access them via the URL option. You will have to consider firewalls and open up ports on the VM.



it is giving below error with below credentials

“The currently selected server type does not support remote hosts”

I’m using
username : Administrator
pass : manage

firewall is also blocked

I’m unable to help without fully understanding the installations. Please wait for Holger or someone else to guide you here.


1 Like

Hi Rameez,

first of all you should get your FW check and opened.

Please provide us with your wM version and the list of Fixes applied to Designer and MWS installation.

I am not yet working with wM 10.x so it seems that connecting to MWS servers in Designer has changed a little bit and now requires a running SPM which manages the MWS servers.



Hi holger…
FW is blocked on remote machine(VM)
SPM is also running.
i’m using wM 10.5 and i’m getting below error while adding server in designer
“The currently selected server type does not support remote hosts”
on community many says to open ports of VM but i tried it by following some internet solutions but messed up my environment settings.
so plz guide me to open the ports.

Have you installed this plugin on your Designer?
Designer > Composite Applications > My webMethods Server Support plugin

Open up the SPM ports 8092 (no SSL) and 8093 (SSL) on the remote VM.

P.S - I’m unsure if a remote server is in fact available as a feature; create a support ticket if the above options don’t work.



No i haven’t installed that component…
will try and update here

Some components were missing and after installing them, I was able to see mws server in server list.

Can you list the components that you missed initially?

Hi KM…
Initially had a customized image in which below components were missing in designer
Composite Applications
Event Development
SOA Governance

Hope this will we helpful


according to this list the most relevant component should be “Composite Applications (Framework)” here.


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.