wm.deployer.Plugin. DeployerPlugin: DeployObjects

I used the wmDeployer for migrate from one enviroment to another, but when run the Simulator i getting a error message:

ERROR The Deploy failed, and automatic Rollback has been selected; thus, a Rollback will be performed. Please see the separate Rollback report. There may be further information here regarding the failed Deploy.

“An exception occurred while performing an invoke of the service: “wm.deployer.Plugin.DeployerPlugin:DeployObjects”. Exception details follow: “com.wm.app.b2b.server.ServiceException: [ISS.0088.9133] Error while encoding RPC output””.

i can’t do the deploy to the other enviroment, until solve this issue.

Did anyone found a resolution for the above error? I got the same error.

Deployer is NOT a migration tool!

Deployer is used to “deploy” applications from one environment to other (DEV → QA → PROD), been the SAME version and recommended fix level.

An interesting topic, This restriction is not in place if you want to move the code from 7.1.2 to 8.0. This might be because of the same version of Deployer on both the 7.1.2 and 8.0.

So far no issues!


did anyone got clear idea for this issue … whether it got resolved?? i too got the same error during deployment…

This was a challenging one. The issue is pretty simple if you look at the error it says "An exception occurred while performing an invoke of the service: “wm.deployer.Plugin.DeployerPlugin:DeployObjects”. Exception details follow: “com.wm.app.b2b.server.ServiceException: [ISS.0088.9133] Error while encoding RPC output”".

if you look closely on the error it says "wm.deployer.Plugin.DeployerPlugin:DeployObjects" which menats it has got something to do with the DeployObjects service.

This issue is because the deployer you are using does not find this service DeployObjects on the target server to execute.

To resolve this move the WmDeployer and WmDeployerResource Packages from the server where you are using the deployer from. Once installed on the target server Go to Package->Management-?WmDeployer packager where select Browse services in the package. Navigate to the wm.deployer.Plugin.DeployerPlugin:DeployObjects and Test the service without inputs. Once done go back into the deployer and create a new deployment candidate do a Checkpoint and Deploy and it should work like a charm. The simulate might same the throw the same error but ignore it.

Another good idea would be to remove the server from a cluster if you are looking at deploying this on a single server instead of multiple at a time.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.