UnknownHostException when debugging IS service

Hi

When trying to debug an IS service I enter some variable values but then get an UnknownHostException in Designer 9.5 on a Win 7 OS.

I created a java class outwith Designer which uses the same InetAddress.getLocalHost().getHostName() method which functions correctly.

I’ve reinstalled 6 times but to no avail & also tried different configerations in my hosts file which has no effect.

Anybody help

Ewan

Hi

This is the actual error after another reinstall

java.net.UnknownHostException: DEV44: DEV44
at java.net.InetAddress.getLocalHost(InetAddress.java:1466)
at com.softwareag.is.flowdebugger.core.model.FlowDebugTarget.execute(FlowDebugTarget.java:1070)
at com.softwareag.is.flowdebugger.core.model.FlowDebugTarget.started(FlowDebugTarget.java:163)
at com.softwareag.is.flowdebugger.core.model.FlowDebugTarget.(FlowDebugTarget.java:114)
at com.softwareag.is.launch.core.ServiceLaunchRunner.doLaunch(ServiceLaunchRunner.java:361)
at com.softwareag.is.launch.core.ServiceLaunchRunner.run(ServiceLaunchRunner.java:245)
at com.softwareag.is.launch.core.ServiceLaunchRunner.run(ServiceLaunchRunner.java:226)
at java.lang.Thread.run(Thread.java:724)
Caused by: java.net.UnknownHostException: DEV44
at java.net.Inet6AddressImpl.lookupAllHostAddr(Native Method)
at java.net.InetAddress$1.lookupAllHostAddr(InetAddress.java:894)
at java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1286)
at java.net.InetAddress.getLocalHost(InetAddress.java:1462)
… 7 more

What does the IS service do?

What is your java service do? I see you are trying to get the ip/host name?

Provide more details to help you better.

Hi

This is a Designer error which happens no matter which IS service I try to debug - it happens BEFORE I get to debug perspective.

I wrote my java class to duplicate the error trace, but the method works in my class so why does Designer throw this error?

Thanks

Can you upload some screen-shots and describe when it happens?

Hi

No screenshots allowed unfortunately.

The steps to create this issue follow -

  • 1. Select flow service from package navigator in service perspective
    2. Right click on flow shown in tab and choose Debug As -> Debug Flow Service
    3. Enter input for service and click OK
    4. Debud Session Error modal dialog appears with hostname: hostname error message
    5. Click OK to close modal and the stack trace copied previously is shown in the Results tab

I have tried on other colleagues machines & they work fine using the above steps, but we cannot figure the difference between our computers.

Also no errors when running a seperate java class to call these methods on the same machine.

Thanks

Ewan

Strange and weird :slight_smile: Not sure what could be the problem. Are you missing some settings in your designer… Try to reset perspective and try to restart the designer.

Update your comments.

Hi

I have re-installed Designer about 8 times using varying configurations to no avail.

May have to raise a support ticket

Ewan

Yes… contact SAG global support.

Let us know their updates.