Flow Service not opening in Developer

Hi I am trying to create a Flow service where in I have EDI 850 ver 4060 as my Input and my Canonical Structure in my Output. After i take the reference on those two doc types in my Input-Output, for some reason , that Flow service is not opening up properly in my Developer.I Dont know if this is a problem with memory or some thing else. I tried celaring up the Cache thru my developer but still could’nt resolve it.
Can somebody help me out with some ideas.

Try refreshing the developer or restart with new session.Could be related to your IS network connection is slow or memory issue so developer is slow which causes services to open hung.


We tried all the possibilites that you mentioned …Could’nt get it solved.Do you think of any other options ? Any help is greatly appreciated.

Did you tried to clone the service and rename?Its weird not seen this behaviour so try r&d if it helps.

Thanks RMG.

Tried different ways like renaming, recreating, deleting and creating the service again etc. For some reason, the service was acting so weird. Dont know if this is a bug but making us crazy.

Let me know if you think of any ideas.


Hi Folks,

I’m having exactly the same problem here.
When I try to create a flow service
that maps EDI 856 4010 to Canonical,
the wm Developer becomes to work weird!

I don’t know if this issue is related with
the use of EDI 856 4010, but it appeared every
time I try to use it.

Have somebody any clue about this issue?!



Can you pls describe on your Developer weird problem?Hope you tried the options told above.

Try clear flowservice cache or increase JVM memory of developer and relogin etc…Also apply developer SP1,If still problem persists contact WM tech support unless the issue becomes crazy.


When you work with complex documents, like EDI, maybe the developer starts to work weird.

in the developer.bat file, just replace the following part:
-Xms128M -Xmx256
-Xss1000K -Xms256M -Xmx512M

This will allow the developer to handle large documents…


I agree with your solution,this is what i have also told to increase developer JVM memory size by editing the developer.bat file.

This will solve problems not only for EDI types,but also for RRNO PIP’s,CIDX,PIDX,OAG Canonical documents etc…


Hi Andre, what is the significance of the lines you mentioned? :confused: