Unable to Move to IS Package from Local Repository

What product/components do you use and which version/fix level?

Microservice Runtime 10.11

Are you using a free trial or a product with a customer license?

Customer License

What are trying to achieve? Please describe in detail.

Hello, So im trying to clone my git package from gitlab and this happened.
I got “Unable to move the project under Integration Server package as linked resource.
The syntax of the command is incorrect.” when i’m trying to move my package from Package Explorer to IS Package Navigator, any idea how to solve this?

Do you get any error messages? Please provide a full error message screenshot and log file.

Does the Designer or the IS Server can show the CLI that they execute from logs?

The detailed error log in the designer is available at Window->Show View->Error log , You can check this log to see if there are more details.

-NP

As per the error message, the Designer doesn’t have write permission to IntegrationServer/packages folder as a normal user. You can change the folder permission and try. And also you can try by starting the Designer as Administrator.

Hi @Biswa_Bhusan_Dalai , i tried to run the designer as administrator and the issue still persist, i tried to check the error log as @Nagendra_Prasad said and this is what i got

java.lang.Exception: The syntax of the command is incorrect.

	at com.softwareag.is.vcsintegration.showfiles.actions.MoveProjectToPackageAction.executeCommand(MoveProjectToPackageAction.java:901)
	at com.softwareag.is.vcsintegration.showfiles.actions.MoveProjectToPackageAction.access$300(MoveProjectToPackageAction.java:111)
	at com.softwareag.is.vcsintegration.showfiles.actions.MoveProjectToPackageAction$5.createSymbolicLink(MoveProjectToPackageAction.java:515)
	at com.softwareag.is.vcsintegration.showfiles.actions.MoveProjectToPackageAction$5.run(MoveProjectToPackageAction.java:500)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)

I have no idea why this is happening still, the folder permissions seems okay, Any other ideas?
Thank you

Can you try running your design with Run As Administrator? I also faced issues with this and run as administrator resolved.

Linking to similar thread - Unable to import existing projects on IS from using Service Designer

still doesn’t work, but i found a temporary solution, what i did is to mklink manually through the windows cmd and it showed on the IS Package Navigator, thank you