Unable to execute modules

Good day,

I have installed the trail version DVD_Version_N1_8.3.5.0.242_CE on my Windows 10 machine but i cannot execute the “Hello world” module. I followed the installations guide on the folder but i keep getting the “connection to localhost 2801 failed”. I attached a screenshot of the error. What can i do to get it running and executing successfully.

Please help…

Hello,

I am wondering why your attached image shows 2 copies of the “Hello World” application? Did you accidentally install it twice, or did the first install not work and you tried a second install? What happened when you ran the first one? Same error or a different message?

NaturalONE Hello World Sample Application
NaturalONE Hello World Sample Application(1)

I suggest deleting the second one, with the (1) appended. Then try to get the first one to work. Two copies of the same application make it difficult to modify the configuration/preferences settings and keep straight which is which.

I don’t know why your error was complaining about port 2801. The default port for NaturalONE to use for localhost should be 2800.

Highlight the first NaturalONE Hello World Sample Application and select Run -> Run Configurations -> Natural Application ->
Default Launch. Select the Natural Server tab, which should show Host Name: localhost, and Port Number: 2800.

Also note that in the SRC directory, the HELLO-A.NS8 and HELLO-P-NSP should not have " ^% " after them That means they have syntax errors or just haven’t been Updated and Saved. Right click on them and select NaturalONE -> Update to catalog the object module. If you made any changes to the source it should also ask if you want to Save source, or click the floppy disk icon on the 2nd toolbar.

If you still get these Port Number errors, I guess you could try deleting both Hello World applications and then reinstall it once, leaving all settings with their defaults.

If nothing works, report back with your results and hopefully someone who knows more than me will answer.

Good luck,
George

Thanks for responding George,

I removed both applications and re-installed NaturalOne but the problem persists. I am unable to update the source code in the SRC as advised because of the same error.

I even tried creating a new project and created a simple hello world program and still i cannot catalog it.

So i created a new project on a different library just to test if the problem is on the “Hello World” application , which is not the case

I checked the Default Launch and updated accordingly, increased the Server run time to 30.

The problem is to do with port 2800 as seen on the attachment, just don’t know how to resolve this one.


Have you checked if you accidentally blocked the port when it started up the first time and asked ?
You can check in firewall advanced setting and see the Natural v.n.n. is blocked for domain usage.
Or - perhaps you are not allowed to make firewall changes yourself ? - (administrator rights)
Finn

Thanks Finn,

I would have to check with the administrator i do not have administrative rights to make firewall changes.

Ntsie,

Finn’s suggestion sounds like it might be your problem. I didn’t realize you were using your work computer with tighter firewall restrictions.

If that doesn’t fix the problem, you might also look around for other software installed on your PC that might also be using port 2800.

Also, while your administrator is looking at the firewall settings, be aware that NaturalONE also uses port 3500 for web I/O, as shown in the Preferences under Window. See attachment.

George

Thanks George,

I will take it up with the Systems admin and see if i can get it resolved.