Sync problem with TaminoMobileSource

When I open the TaminoMobileSource adapter with createXMLDatabase(), I have no problems doing a sync. All the data that were inserted are inserted in the Tamino Server DB.

My problems start when I try to open the adapter with openXMLDatabase(flag). At first I used it without the flag and not even inserts worked, I only later figured out that it’s because the db is opened as read only. (not that an error message is given when using performInsert). I then opened the db with all three possible flags and managed to get it to insert the data but no it doesn’t sync.

How do I get it to sync? I don’t want to use createXMLDatabase, as I need the data even if the virtual machine is switched off.

I don’t know if I do get the problem properly.
If you want to use automatic sync, then it’s not important, that the db is created before, but that an insert/update was made in the database, so that there are data to be synchronized. If nothing has changed, then nothing is synchronized.

Is there an exception or what does happen?


Hi Waltraud,

I initially didn’t have to store the data in my db on the mobile and just did a createXMLDatabase to start the application. But now it has become critical that I store the data, even if the Jeode server stops. That means that I have to do a openXMLDatabase when I start the application.

After changing to openXMLDatabase I could not insert records with the performInsert method, I then changed my code to do the insert with the DOM. Only then did I get an error that the database is read only. I then used openDB with the flags option, specifying that I can write to the database and only then did my inserts work again.

Now when I do a sync, the sync completes with code 100, succesfull but it doesn’t actually sync the data. I think the problem might be with the flags that I’m specifying with opening the database.

Should I be able to sync if I use the default openXMLDatabase() without any flags? If yes, then why doesn’t it work.

Regards, Jean

You have several possibilities as you already described, but it is important that you open the database with the same flag settings that you used, when you created it.
If you get return code ok and the no sync is done, then perhaps a rollback in Tamino is done.

If you feel there is an error, then please let support know and send an example so that we can help you.


Thanks Waltraud,

I do think that there might be something wrong, as I would expect both methods to work the same when I don’t specify flags. Surely the default for both methods must be the same?

Could you perhaps tell me how to contact support? Should I go through our local office in South Africa?


Hi Jean!

To contact support either contact your local office, or if you already have a valid user-id you could go thru
→ Request Management to open a request.