Creation of a database in Tamino

Hello,

whenever I recently tried to create a new database I got errors and the following messages:

>Could not add XTS entry for database >xapplication on “computername.domain” with port >3206
–> MessageID = INOAAE0172

and then

>fail - query registry key >HKEY_LOCAL_MACHINE\SOFTWARE\Software >AG\Tamino\servers\xapplication\ID
–> MessageID = INOAAE0753

I really do not know what mistake I might have made, as I already created a database a few days ago and did not have any problems.
I hope somebody can help me there!

Thanks in advance.

Hi,

two things come to my mind:

For each new database 2 ports are allocated. Maybe the ports to be allocated are already taken by another application (web server, SAP client, things like that)?

As you see, Tamino tries to write values to your registry. Do you - under your current login account - have the privileges to do so?

If this problem persists, I’d encourage you to contact Software AG Customer Service Center.

Best regards,

Andreas

Hi,

I have faced hte same problem, and while cheking out I found every thing to be right. Like the ports were available, I was in Administrator privileges etc. Then after breaking my head for some more time, I realised that the registry has already meet the maximum size limit, specified for it.

If possible also just check out the registry size and do the need ful.

Best Regards,
aniL

Hello!

Could any one provide solution to Keks’ problem? I just installed Tamino and launched it. I wanted to create a database…now I didn’t specify any back-up file or anything and got the same error as Keks got.

Can any one please help me get going with this or suggest any web site where I can get some more information as to how to create a database?

Thank you in advance,
Syed

Well I would suggest starting from basics:
Are all the daemons running? Under what account did you install the software? What is the ownership and protection mask of the xtsurl.cfg file lurking at the bottom of the /sag/common/xts subdirectory tree? Do you have the XTSDShost and XTSDSport settings correct in /etc/hosts?
*
Check these and then lets see.

Kind regards,

Simon

Thank you very much for the response.

Finally, I managed to create a database. The SAGXTSDShost entry was missing in my host file. After I added that, I got it to work.

Thank you again!

Syed