Problem with Loading Data

Hello, Iam trying to load data in a collection with tamino manager. I get this error : http status code 400. I have disable all security options and my personal firewall under windows XP but I still receive this error. I have also checked if all software AG services where started and that’s ok. I have tried to make queries to the database with the interactive interface and it response correctly. In fact all seems to be ok exept this error. I ask my self if the error could perhaps come from Javacode (The data Loader) but iam not sure. Do you know what could be the reason of this error? Thank you

If you find the answer please email me. I also get the same error but only on some machines. On the ones I do get the error I use argbatch load data and set the db to tolerate depracated commands.

Status code 400 is produced at serious communication problems only, such as create socket error or send/receive errors. Please check your network environment. If the problem persists, please report this to your local Software AG Support Centre. The Data Loader (inoload) does not use any java code, by the way. Best Regards, Reiner

Hi I found a solution that worked for me. Step 1. Goto DOS command and run “ARGBATCH CLEAR ENVIRONMENT” Step 2. In your inoload statement specify with the -server parameter the XML port as defined when you installed Tamino. On my machine 3201 So enter the command as follows: “inoload -function load -server machinename:3201 -user …” According to the “inoload -help” you can either specify the database name or the server but not both. I do have a problem with it. If you have 2 databases on your server db1 and db2 both with the same Schema/Collection/DocType, how does this command know which one to update? From what I have seen you cannot use -database and -server on the same inoload command. Step 3. Make sure the path to the inoload program is in your PATH statement. It is with a normal installation installed at “C:\Program Files\Software AG\Tamino\Tamino\bin” assuming you have Tamino 4.2.1. Hope this helps. Naas

I have the same problem trying to load a 48MB XML file with many documents inside. The error I got is: With -server = … <ino:message ino:returnvalue=“6583”> <ino:messagetext ino:code=“INODCE6583”>Cannot contact Tamino Server - HTTP status code 500 received</ino:messagetext> </ino:message With -database = … <ino:message ino:returnvalue=“6583”> <ino:messagetext ino:code=“INODCE6583”>Cannot contact Tamino Server - HTTP status code 400 received</ino:messagetext> </ino:message> I was tunning the server with the timeout but it doesn’t works Do I have to change some other parameter in somewhere?? Joe

Joe Are you using XTS and TCP? Go to Tamino manager, select your database, Properties, Server and then look for the ‘Communication Method’. Select XTS and TCP/IP. Stop and restart db and try again.

The databases db1 and db2 have different XML ports. So port 3201 identifies exactly one database.