loading data from data loder in command line problem

hello !!
i want to load data to tamino using data loader using command line and i get this error :
[color=“red”]

  • Tamino Data Loader v4.4.1.1 - (c) Copyright Software AG 2002-2009. All rights reserved. Started at 2009-08-10T14:39:22
  • Port number is required
  • Tamino Data Loader finished with errors at 2009-08-10T14:39:23 [/color]

the command in line is
inoload -function load -server http://the-server-ip/tamino/nameTest:3121 -user Administrator -collection /Reports/Forat -input D:\Net\red\Forat .xml -log D:\Net\red\xyz.xml -mediatype xml -concurrentwrite

also i am doing that becouse i have a very larg files and i need to load it automaticly (programiticly) so if yo have any suggestions for the task i will be glad to know!!
thank you !!!

I havent’ checked all your parms but the serverURL looks wrong !?
what about
http://the-server-ip:3121/tamino/nameTest
Finn

hi! ,tnx for fast replay! i fixed the issue with the port number as you said,
but now i get error that
“can not contact tamino server http status code received 502”
and i see the same error in the tamino manegment -> logs…

if i will try work locally on machine who runs the tamino server , do i need to change the way i write the command ?
do i have to mention the full server url?
what is the difference between “-server” and “-database” arguments?
thank you and best regards!

Hi Net

  • And you are sure 3121 is the XML port of the remote DB ?

If you do the dataload locally, the basic syntax I usually use, is something like this:

inoload -database MyDB -collection Mycoll/MyDoc -input *.xml -log log.txt

or with your data:
inoload -database nameTest -collection /Reports/Forat -input D:\Net\red\Forat .xml -log D:\Net\red\xyz.xml

You should only use the concurrentwrite if there has to be access for other users while you do the massload - load without this option is MUCH faster !

Finn

hi! i tried the loader on local machine (the tamino runs on it) and it works good,
thank you for the help !!!