Starting demo database woes

There are numerous threads on that subject, however I’m still stuck with starting the demo database.

- Tamino XMLSpy Developer Edition
- W2k Pro

http://localhost:9991/smh/login.htm
-----------------------------------
Managed Hosts -> 'g7’

C:\WINNT\system32\drivers\etc
-----------------------------

When I put the following entry in the “hosts” file

127.0.0.1       SAGXTSDShost</pre><BR><BR>I do get the following error:<BR><BR><I>Failed to create XTS directory service entries: XTS1061E: TCP/IP Connection refused  </I><BR><BR>same is true for<BR><BR><pre class="ip-ubbcode-code-pre">192.168.100.2       SAGXTSDShost</pre><BR><BR>(where 192.168.100.2 is the IP within my local network)<BR>_____________________________________________<BR><BR>When I comment out the entry above, I do get this error:<BR><BR><I>Failed to create XTS directory service entries: XTS0080E: XTS GetHostByName Failed </I><BR><BR>_____________________________________________<BR><BR>Could somebody please provide some sort of a troubleshooting guide, since this seems to be a common pitfall.<BR><BR>Btw - during installation I decided to not install the DNS Server as discussed in the "Installing Tamino on Windows" PDF (p.10), hosts entries are made by the installer.<BR><BR><pre class="ip-ubbcode-code-pre"># Software AG # Start # Extended Transport Service #
# 2.1.1.4 - 2002-11-18-09.22.09
192.168.100.2       SAGXTSDShost
# Software AG #  End  # Extended Transport Service #



_____________________________________________

TIA,

ralf …

Hello Ralf,

maybe you have already tried this, but I have an additional entry in my hosts file:
49.187.0.0 sagxtsdsport

If no one has a better solution, maybe you could try this too?

Greetings,
Trevor.

Hi Trevor, thanks for your suggestion - I just tried it - without success :frowning:

Well, the PDF mentions that Tamino will use 49.187.0.0 as default value, if it cannot resolve SAGXTSDSport, so I guess it probably doesn’t matter whether the entry does exist or not. Or maybe I need to put in another value?

Also, when I click on

[g7]
|_____ Extended Transport Service
|___________ Directory Servers

there is a [!] warning, which says: "Add Flat File"

XTS Agent Failure -> No Directories have been defined!

Could that be the cause of the problem?

Any further ideas greatly appreciated.

r.

Finally - a little step foward :slight_smile:

I (re)installed the Directory Service and realized that the service was not running.

C:\Programme\Software AG\Extended Transport Service>xtsdssvc -status
The XTSDirSrv service has not been started.

Name = "XTSDIR"
Port = 0
Directory = "INIDIR"
DirParms = ""
LogDir = "C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Software AG"
Trace = 00000000
Debug = 00000000</pre><BR><BR>After reading through the threads and the readme file I changed the dirparms manually like that. <BR><BR><pre class="ip-ubbcode-code-pre">xtsdssvc -dirparms "file=c:\Documents and Settings\All Users\Application Data\Software AG\xtsurl.cfg"</pre><BR><BR>Now the service seems to be running fine:<BR><BR><pre class="ip-ubbcode-code-pre">C:\Programme\Software AG\Extended Transport Service>xtsdssvc -status
The XTSDirSrv service has running status (4)

Name = "XTSDIR"
Port = 0
Directory = "INIDIR"
DirParms = "file=c:\Documents and Settings\All Users\Application Data\Software AG\xtsurl.cfg"
LogDir = "C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Software AG"
Trace = 00000000
Debug = 00000000



Unfortunately the database still doesn’t start up - though the error message has changed to:

Failed to create XTS directory service entries: XTS0226E: DS Create file failed

Any ideas? Was changing the dirparms a step into the right direction?

TIA

ralf …

OMG, it was a step into the rigth direction + it’s finally up and running. In the example above I was accidentally using the english system path. The correct path on a german system has to be:

DirParms = "file=c:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Software AG\xtsurl.cfg"


So, for the records: the installer obviously doesn’t fill in the proper path on some machines …

Phew.

ralf …