Failure while starting database: ".. Failed to create XTS di

System: Linux Suse 7.3, Starterkit 3.1.1.1, Eval-License, Java (build 1.3.1-b24), Apache from Starterkit, PII 300, 64MB RAM

The error occurs while starting the database. Here the complete log:

#################################################

Starting database ‘test_db’ INOAAI0574 2002-04-15 16:03:29

Tamino server 3.1.1.3 on Linux x86 INODSA1002 2002-04-15 16:03:29

Only 3 concurrent XML sessions licensed. INOXHW8232 2002-04-15 16:03:30

The Tamino Server that is provided with the Tamino Developer Edition may be used for test purposes only. For production purposes, you must use the Tamino Server that is included in the Tamino Server Edition INODSI1456 2002-04-15 16:03:40

Failed to create XTS directory service entries: XTS0080E: XTS GetHostByName Failed INODSE5271 2002-04-15 16:03:43

Terminated with errors INODSF1436 2002-04-15 16:03:46

#################################################

I have no idea how to solve this problem, and i

Hi Felix,

use the “hostname” command to confirm that the computer has the name that is registered as a node in the System Management Hub.

I think that I had a similar problem after changing the name (but not the IP address) of my PC.

(If the names are different, just select the “Managed Hosts” tree node and click on “Add Host…” to add the new name.)

HTH,
Trevor.

thank you for your quick reply!

… i fear, that was not the reason … i never changed the hostname. anyhow, i tried your proposal - but without success.

i

Hi Felix,

perhaps you should modify the following property:
-> Tamino -> Databases -> -> Properties -> Server -> Overwrite XTS Registration

Set the value to “yes” (you need to click the “Modify” button in the lower left pane) and restart.

TF.

i tried your suggestion, but without success … i also craeated a new database in a new location whith your settings, but ditto the same error.

best regards,
felix

Check the entry for SAGXTSDShost in /etc/hosts:
127.0.0.1 localhost SAGXTSDShost

indeed, in the hosts file there was no entry SAGXTSDShost. now it works very fine!

sincere thanks for all your help!
felix

Where is SAGXTSDShost?
Can’t seem to find it… where do i change it from?

SAGXTSDShost entry is found in the host file, that is on UNIX /etc/hosts and on Windows it is %systemroot%\system32\drivers\etc\HOSTS .

Hi,
I hope I’m posting this in the correct place.
We’re using 3111 on Solaris 8. When I try to start the sagxts service, I get this response:

$ Error -88 (XTS0088E: XTS No CONNECT or LISTEN has been issued) while starting XTSDS

argsrv, argevsrv, and argmlsrv all appear
to be running properly.

I think /etc/hosts is configured correctly
(I just double checked).

Any ideas?

This problem is probably caused by XTS directory services not running. There should be a process called ‘xtsdsdmn’. This is normally started during system startup by a script called /etc/init.d/sagxts . Could you check that?

Hi Stuart,

Thanks for responding. Yes, I know about the sagxts script in /etc/init.d. The error message is
occuring when I run that script. I’m hoping to get some ideas about why I get the error message (above) when I run /etc/init.d/sagxts.

-leigh

Hi,
I found a technical document (Document ID 212329) on this problem in the servline24 database, so I’ll proceed with that. Thanks.

Hi,
here some remarks for other users with the same failure.
Our system:
Solaris 8 with Tamino 3.1.1.1 (32bit mode)
During installation in /etc/hosts entries are added for SAGXTSDShost and SAGXTSDSport. This should be correct. But if we using NIS (YP) there were some problems.
The command “hostname” gives only the name (without any domain), but this entry is marked out by the installation procedure. After reverse changing I was able to create a database but starting the database wasn’t possible.Playing with entries in /etc/hosts changed nothing. The solution was to change the NIS Table “hosts” and add an alias SAGXTSDShost for the specific machine.
Other way to reach this is changing the search order from resolver (file before nis).

Hope this helps someone.
Lips.

When trying to start a database, I’m getting: Error INODSE5271, "Failed to create XTS directory service entries: XTS1061E: TCP/IP Connection refused"

I’ve checked the hosts file and the hostnaming as specified above. Are there other things I should be doing?

Thanks,
Jeff

sorry for this Q…but how can i change the entery?? cuz am facing the same problem and i found 192.168.1.9 insted of 127.0.0.1 Regards