SQL MAPPING.. unable to update schema.. error with PRIMARY K

I am trying to create a schema that maps to a table and columns in either an Oracle or MS-SQL database but i keep getting the following error when I try to update the schema:

Invalid mapping specification: invalid or unexpected primary key definition

I made sure the primary key value attribute of the schema is the same as the primary key in my Oracle and MS-SQL tables, but I still get the error. Please help!

Thx in advance!
-pod

I am using tamino version 2.3.1.4. It seems that there is a problem with the schema editor and double quotes:

here is the line from the schema:

<ino:node ino:name=“ORACLE_EMPLOYEES” ino:key=“EMPLOYEE1” ino:obj-type=“SEQ” ino:parent=“id0000000002” ino:search-type=“no” ino:map-type=“SqlTable” ino:datasource=“tempOracle” ino:sqltable=“EMPLOYEE” ino:sqlprimarykeys="“EMPLOYEE_ID”" ino:sqluserid=“system” ino:sqlpassword=“manager”/>

I think the ““EMPLOYEE_ID”” is giving a problem. I even tried it with single quotes… to no avail.

Thx for any help,
sauropod

In case anyone’s interested, you have to do this in the textbox for SQL Primary Keys:

"EMPOYEE_ID"

This is because it needs quotes… However, you CANNOT do this: “EMPLOYEE_ID”

…Because then u end up with double quotes in the schema file and it becomes non-well-formed and the XML parser will throw an error.

The browser converted my character: & quot ;

into a ".

You have to use the escaped character: & quot ;

  1. create your mapping with the schema editor

    2. open schema in editor

    3. ino:sqlprimarykeys="“ID”" -> use " instead of " to embedd a key

    4. save schema

    5. send schema via Tamino Interactive Interface to your database because the Schema Editor has problems with " and "

    6. now you can get the schema from the database even with the Schema Editor

I meant ‘& quot;’ instead of " (write it together)