Software AG Designer startup options

Hi,

I am trying to improve the startup of Software AG designer or the ZULU JDK on the Windows platform.

I have already changed the ECLIPSE.INI file to use more memory but it still takes 3-5 minutes to load . Changed the XMX1024M to XMX4096M.

a) It startups with the following command :

C:\SoftwareAG\Designer\eclipse\eclipse.exe

b) The intial startup options are in :

C:\SoftwareAG\Designer\eclipse\eclipse.ini

My ECLIPSE.INI file contains :

Launch configuration settings for Software AG Designer

For information, refer to the Software AG Designer documentation, available as online help in Designer itself or on the Software AG documentation website.

-product
com.webmethods.product.designer.ide
-startup
plugins/org.eclipse.equinox.launcher_1.5.300.v20190213-1655.jar
–launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.1000.v20190125-2016
-showsplash
com.softwareag.common.eclipse

The following option is only applicable to Java 7 and earlier

–launcher.XXMaxPermSize

256m

-vm
C:/SoftwareAG/jvm/jvm/jre/bin/javaw.exe
-vmargs
-XX:+UseG1GC
-XX:+UseStringDeduplication
–add-modules=ALL-SYSTEM
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx4096m
–add-modules=ALL-SYSTEM

Note: I did see that it uses the ZULU JDK : http://docs.azul.com/zulu/zuludocs/ZuluUserGuide/Title.htm

Start as in : https://www.youtube.com/watch?v=QvXLuHtNeS0

Anton

Feedback :

If you change your startup options to the following, it makes a BIG difference :

Xms256m - > Change this to Xms1024m
Xms1024m - > Change this to Xms2048m

Also, switch OFF automatic updates :

  • Title Bar
  • WINDOWS
  • Preferences
  • Install/Update
  • Automatic Updates
    • Switch off Automatically find new updates

Anton