Security syntax for XML RPC server

Hi All-

I’m trying to run the jxmlrpcserver from the pc command line against a broker running on the mainframe and get the ‘inconsistant security’ error. Does anyone know the syntax to add the security attribute to the entirex.xml.runtime.configuraiton.xml file?

Thank you,
Chris Webber
State of MN

I’m guessing a little bit because you have not noted the error code but only the message.

Have you installed the stub on your side without security and the Broker is running with security or visa versa? This must be consistent.

Regards,
Mogens

Yes, the stub was installed with security as well as the main frame installation.

I have also tried to run against a broker on my PC and found that if I turn the security attribute to NO the XML RPC server runs fine. If I change the attribute to YES I again get the inconsistent security message. This leads me to believe that I must somehow tell the XML RPC server to use security.

I’ve tried adding various tag names and values to the mentioned config file but have not had any luck.

Ultimately, I want to program for a Natural program on the mainframe to call an external Web Service.

Thanks,
Chris

What is the exact error (including the error code “nnnn nnnn”)?

Is the security you are running in Broker on mainframe EntireX Security? Is SECURITY=YES set in Attribute File and is the module USRSEC which is accessible for Broker through STEPLIB (or linklist) coming from the EntireX installation?

Regards.
Mogens

Hi Mogens-

Here are my answeres to your questions:

Is the security you are running in Broker on mainframe EntireX Security?—Yes

Is SECURITY=YES set in Attribute File ----Yes

Is the module USRSEC which is accessible for Broker through STEPLIB (or linklist) coming from the EntireX installation----Yes

Here is the last bit of my command line output:


2004-08-20 15:00:46.131/main LOGON returns: EC=00200379,TXT=API: Inconsistent
Security Installation

2004-08-20 15:00:46.147/main Broker Error 0020 0379: API: Inconsistent Security
Installation
Broker Error 0020 0379: API: Inconsistent Security Installation

2004-08-20 15:00:46.147/main Stopping XMLRPCServer.

2004-08-20 15:00:46.147/Thread-1 LOGON returns: EC=00200379,TXT=API: Inconsist
ent Security Installation

2004-08-20 15:00:46.147/Thread-1 Broker Error 0020 0379: API: Inconsistent Secur
ity Installation

2004-08-20 15:00:46.147/Thread-1 Broker Exception in server:
Broker Error 0020 0379: API: Inconsistent Security Installation


Thanks,
Chris

Hi Chris,
Please verify that the file “secuexit.dll” exists under the folder “Program Files/Common Files/Software AG/”. The EntireX runtime on WIndows needs this file to run secured.
Rabia

Yes, the secuexit.dll file exists in the proper folder.

Thanks,
Chris

Can you run Broker Control Center against the same Broker?

–> Start / Programs / Software AG EntireX Communicator / EntireX Broker Control Center

Regards,
Mogens

Yes, I can run the control center aginst the broker. The security attribute for the broker is set to ‘YES’.

Chris

Sorry, but then I have no additional ideas.

Maybe you should consult your local Software AG support if nobody else can help in this forum?

Regards,
Mogens

Chris,
I do not know which version you are using…
Please check document id: 517664 on Servline24. There is a similar problem and it is sovled with latest hotfix of the entirex.jar file of version EXX711PL31f.
Rabia

I have installed all of the latest hot fixes and am still getting the same error. I will open a trouble ticket.

Thank you all for your attempts to help me.

We can close this thread.

Chris

Hi Chris,
had the same prob and solved it using parameter “-Dentirex.server.security=yes” at java start. Hope this will help you too.
Axel

This scenario works.
Here is portion of the the entirex.xml.runtime.properties

entirex.sdk.xml.runtime.configurationfile=
entirex.xml.runtime.configuration.xml
entirex.server.security=yes
entirex.server.userid=SHMUELK
entirex.server.password=???

The broker is on the z/OS - the user is autheticated, then user permission “to register the service” is checked via SAF.