Error class: 20 Error code: 379 API: Inconsistent Security I

Hi all,

I am an absolutely newbie to Communicator, I have started a Broker (ETB001) @ 1971 using only TCP protocol from the Broker Administration. However when I try to browse the Broker Properities via SMH , I get this

Error class: 20 Error code: 379 API: Inconsistent Security Installation

Can anyone advice me what do I need to check in order to make the security consistent ?

Hi Irwin,
The most probably cause of this is that you have made a default installation, that enables client security.
When you create a new broker however, security is not on by default.
The “quick and dirty” way to get round this is to rename the secuexit.dll which you can find in
C:\Program Files\Common Files\Software AG
and then restart.
The right way is, of course, to reinstall without security.

Hi Irwin,

as Finn mentioned the problem is due to the fact that (with the default installation) the security option is selected and this results in the secure DLLs to be installed. You can also run through the EntireX setup program again and deselect the secure option. This should remove the required DLLs and leave everything else working.


As far as I have seen up to exxv7.1 secuexit.dll is the only thing added when security is selected in the install - you can simply remove or rename it.

Hi all,

Thanks for the help ! Now I know where to get help with funny tricks :slight_smile: