remotely bootstrapping SPM

I recently tried to bootstrap an SPM on a remote linux machine (RHEL). The installation seems to run OK, every job in the job log gets a green tick.
When I go onto the machine, I can see SPM running. Starting and stopping SPM doesn’t seem to spawn any errors.

However, CCE doesn’t ‘see’ the SPM.
I’ve tried some basic troubleshooting. TCP/IP setup seems allright, there’s no firewall (see also log entry below to see that confirmed. I can run curl to the SPM from CCE. The inventory cannot be updated and SPM is displayed as “not available” in the Installations section.
This time around, during setup I’ve set the SPM up with SSL port 8093, but doing this exercise without SSL on port 8092 gives the same result.

Hints and tips to resolve and/or troubleshoot this further are more than welcome.

should’ve mentioned that I bootstrapped from current git repository and connected to the SAG Empower. Everything is on version 10.3 therefore.

Looks like SPM is installed with a default password of manage despite giving trying to install it with another password (same as CCE).

I did a manual SPM install and added it later to CCE, that worked like a charm.

Mike, did you look at this template for remote SPM installation?
https://github.com/SoftwareAG/sagdevops-templates/tree/master/templates/sag-spm-boot-ssh

It does allow you to use a non-default password for the SPM Administrator user

Thanks
Sergei

I was not aware of it. Thanks,

Mike