Configure SSL for Software AG Update Manager Installer


First, forgive me if I’m posting in the wrong forum. I couldn’t find the best match for the subject that I’m in need.

I’m trying to install Update Manager on a Windows 10 Pro workstation. I already defined to Update Manager to use our proxy with the credentials, but when he tries to connect it gives me the following error:

“The exit code is 171 […]. You can view the log here:”

One thing that I know is that inside my network we have to use a specific SSL certificate to get access to download from a external source. Otherwise the connection to won’t work.

But I didn’t find anything in Update Manager about a setting to use SSL option. I remember that on “Software AG Installer” it does have a option to use SSL in the first step but doesn’t have on Update Manager.

What should I do to fix this?

Thank you.
launcher.log (16.2 KB)

What is your SUM version?

Refer the link if this helps:

Also, you can install the fixes via Command Central.

Hi Mr. Mahesh.

In the “About” window of SAG Update Manager I got these numbers:

Software AG Update Manager 2019-08 (build )

I also checked this documentation, Empower sent to me too. On page 19 I can read the following:

“Run Update Manager again, but this time select the Use SSL to connect to the
Software AG Update Manager Server option on the Proxy panel. Using SSL may
allow installation to continue despite security appliances because the streams
will be encrypted; the encrypted streams should not trigger anti-virus, antimalware, or other scanners”

But this “Use SSL to connect to the Software AG Update Manager Server” option doesn’t exist in the proxy configuration panel inside the update manager. Please, see the screenshot.

Thank you.


I managed to add my SSL certificate to be used by Update Manager. I used the following command:

[Update_Manage_root_folder]/jvm/jre/bin/keytool -keystore [Update_Manage_root_folder]/jvm/jre/lib/security/cacerts -importcert -alias MyCertificate -file [Your_Certificate_File]

Now this SSL issue it’s solved :D.

But, I thought that it would be easier… Unfortunately, now I have another issue…

When I try to download the Updates from Empower, it gives me following error:

“2019/08/08 08:22:40.283 BRT: Connecting to empower for authentication…
Error: Error connecting to empower. Code:302”

When I define our proxy, I get this result:

Proxy Password:2019/08/08 09:21:23.973 BRT: Initializing connection with repository
Error: ProvisionException (second) when load of repo: exc:HTTP Server Unknown HTTP Response Code (302):
Error: ProvisionException when load of repo: exc:HTTP Server Unknown HTTP Response Code (302):
Error: HTTP Server Unknown HTTP Response Code (302):

Now I don’t know what do to. Please, is there any advice?

Thank you.


I managed to solve the problem. It was a network restriction.

After we allowed access to* domain everything went right.

I figured out this by trying a cUrl to* then I saw that this address was blocked.