RedHat - MWS installation via CCE failed

Product/components used and version/fix level:


Detailed explanation of the problem:


I’m encountering an issue while installing MWS via CCE on a Red Hat 9 server:
The command executed for the installation is as follows:

./sagcc create instances local MwsProgramFiles db.type=mysql
db.username=WM_IS_MWS db.password=******
http.port=8585 jmx.port=7000 install.service=true

The installation failed, and I have an error message:
ERROR: Instance default already exists.

Note: I tried to change the instance name, but each time I receive the message indicating that it already exists.

Please find attached the log for more details.

Thank you

Error messages / full error message screenshot / log file:

MWS.log (6.1 KB)

Question related to a free trial, or to a production (customer) instance?


I’m able to install MWS 10.15 using CCE on Linux . Followed below steps.

  • Added product image to repository
  • Added latest fix image to repository
  • Installed MWS and dependent products from CCE
  • Installed Fixes from CCE
  • Created default instance
  • Here is the trick sometimes the MWS DB account password is updated incorrect … go back to installation path /MWS/server/default/config/mws.db.xml and updated the right password.
  • Now start the MWS from CCE .
    These steps worked for me. Hope this helps .

I never liked the CC installer. It can fail because of several reasons. I assume you already installed platform manager to that node already. Did you check if the ``{sag_installdir}/ MWS/server/default exists? If it says the default instance exists, it probably does. Also check if you have the necessary permissions to the installation directory. It should be owned by the user that platform manager is bound to. Recently I had an installation directory bug. Had to delete the softwareag installation directory completely, to install MWS. Even support couldn’t tell what was wrong with my installation directory.

Btw, in my opinion its much more easier to create an installation script and run them remotely.

1 Like

Thank you for your message. I’ve checked, and it seems that {sag_installdir}/MWS/server/default does not exist on the server (empty).
I admit that installation via CCE is not ideal :slight_smile:
Do you happen to have the procedure for installation via script?

Thank you.

Thank you for sharing the steps you followed. I’ve actually tried the same steps, but unfortunately, I’m still facing issues.
Any additional insights or suggestions would be greatly appreciated.

Its pretty straight forward. Just run the installer, select create installation script at the beginning and show the path, select the products you want to install. Then you can copy the installer + image + script to remote server using scp, and then run the command remotely using ssh. Check the documents below for more information.

You can run a command remotely by
ssh user@server "command to execute" &
and then loop through your servers, from a here file or from just generating dns strings, etc. The & at the end is for paralel execution. It will wait the command to finish if you don’t include it. You can finish the installer command with > install_output.log to have log output ready just in case.

FYI, I assumed you know how to create an installation image as well. Assume you already prepared the installation image.

On additional advantage of the installation script approach is that you can place the script file under version control. So if there is a compliance issue, you can just pull it out and say “this is what was installed”.

Perfect, that’s great. I will try an installation with the script.
Yes, I have already generated an installation image.

Just one last thing, do you have the Linux command to launch the script with the installation image? Because in the SAG documentation, it only covers installation on Windows.

Thank you for your prompt and relevant responses.


<InstallerExecutable> -readScript <Script-File>


Its also in the document I shared. It starts with sh, but instead you can provide execute access to the installer by chmod +x {installerfile} and then run as {pathto installer file}/{installerfile}. The path will be . If you are running from the directory itself.

FYI, installer tells you the required parameters when you execute it directly (for console mode).


In the end, I reinstalled using the script and it’s working better.
Thank you for your help.