Problem with the ENTER key on numeric Keyboard

I have a trouble on numeric keyboard. When i run one program ou sub-program on Single Point that have a input, the enter key on the numeric keyboard do not work.

Can anyone help-me?

Tanks a lot in antecipation!!!

What OS are we talking about? Do you use a Terminal Emulation?

The problem is almost certainly your terminal emulator.

I have no trouble with Natural 6.3 or 6.2 on the PC, and no trouble using Natural Connection to connect with the mainframe.

I used the numeric ENTER key for both interpage (using WRITE) and for INPUT statements (both alpha and numeric fields).

Does the ENTER key (numeric) work for some of your screens, but not others?

steve

Hello Matthias, thanks for your reply!!!

Im using the Software AG Natural Studio 2006 version 6.2.3 (rev 7689) on Single Point.

This development client software is running over the Windows XP SP2.

The host software versions is: Natural 6.2.4, Natural IDL Generator 6.1.1, Natural Development Server 2.2.3, Natural Security 6.2.4

The host is running over Red Hat Enterprise 4 AS (Advanced Server).

When i run one natural program, and then press the enter key on numeric keyboard.

Thanks in antecipation.

Hello Steve, thanks for your reply!!!

In all screens the Numeric Enter Key and PF Keys does not work.

When you press any PF key, or Enter at numeric keyboard, the Natural Studio show a message “Connection lost”.

So, i need to use the CTRL+ALT+DEL key to kill the program process and start the Natural Studio again to work.

AFAIK, there are no options regarding the key-mapping in the SPoD Terminal Emulation. So the only thing you can do is to change the Environment-Variables NATTERM and/or TERM on the SPoD-Server-Side.

http://tech.forums.softwareag.com/viewtopic.php?t=7159

We used the Terminal Emulation under NAT 6.1.1 for Windows, connected to a SPoD-Server on Solaris --> we got many instablilities.
So we went back to another Terminal Emulation (i.e. PuTTY). Of course you have to start it separately, but you can do the Key-Ajustments in the settings on client side…

You can configure your SPoD terminal emulation. In your program installation directory (e.g. C:\Program Files\Software AG\Natural\6.3\Terminal\Config), start PCCAdmin.exe. Open the profile NATSHARE411.SAG from your Etc directory (C:\Program Files\Software AG\Natural\6.3\Etc). (Of course, a backup of NATSHARE411.SAG is recommended before you start tweaking!)

Steve, Matthias, Douglas… Thanks a lot for the reply… I will try and come back to the forum to give answer about this subject.