Terminal Emulation UNIX - PFkeys not working

When I try to run a program from SPOD the PF keys are not working. If I make the mistake of hitting a PF key Natural freezes and I have to use CTRL ALT DELETE. From the SAG list I see something about NATSHARE411.SAG. But what do I do to this file? How does SPOD know which one of the host sessions to use? I tried deleting all the host sessions except NATURAL-VT and tried changing the font (something obvious I would see) but the font is exactly the same, and no PF keys. So I am stumped…

Windows XP (firewall off)
Natural 6.1.1 PL 13

Red Hat Linux Version 3
Natural 6.1.1 PL 13
NDV 2.1.3

Priscilla Fuller

We got the same problem a few months ago. It depends on your $TERM-variable under LINUX. Our’s is now set to vt220. And it’s working …

Sorry, that was wrong…

The “corpus delicti” is $NATTERM, which has to be set to “vt100”.

Matthias - $TERM is set to ansi and $NATTERM is blank. Our Unix boffins aren’t here at the moment so here’s my ignorant question - where do I set this up?

You’d probably want to do this in your script starting the NDV Server.

It depends. Do you start your development-Server on the Linux-Computer manually?

Then just enter:

export NATTERM=vt100

After that, start your development-server:

natdvsrv -p3000

Note: replace 3000 with your specific port.

If the development server is started automatically, the commands above are in some kind of startup-Script anywhere on your Linux-Computer. In that case, you have to ask your “unix boffins”.

Thanks - This is much better!
I am getting a bit further but it is still not quite right - I tried vt220 and vt100 in our startup script and vt100 seems to be the one. I set both $TERM and $NATTERM just to make sure… I can now use the PF keys but I don’t see 2 lines for the PF Keys.
I am expecting to see:
help retrn quit flip bkwrd frwrd print main

(There should be some blanks between - e.g. PF7 is frwrd, PF12 is main)

But I see 1 line only
Enter-help retrn quit–PF4—flip–PF6—PF7—PF8—PF9—PF10–PF11–main—

This is from the Construct demo library - NCSTDEMO.

Is there something else I need to set?
Priscilla Fuller

Hmmmm. Seems not to be a problem with the $NATTERM-assignment. Sorry, I haven’t a clue…

Just use the Code-Button for that.

[code]test       test        test        test[/code]