Cannot see libraries on PC

We have added NDV to a server and I cannot see the libraries on the PC. We have NDV on another server and I can see all those libraries on the PC, so I don’t think the problem is on the PC side. What am I missing?
NDV was added last. I am not using NDVPARM - is there something set there I need to set on the parm I am using?

Red Hat Linux 3
Natural and Natural Security

Could it be, that the (Natural) security definitions are different on the one server ?

As far as I can tell the definitions are the same. Is there anything in Natural Security defaults/ options that has to be set, which would have been set if Nat Security was installed after NDV? I have defined NCSTDEMO (the Construct demo library) with no restrictions whatsoever and I cannot see that library either. I can LOGON to any of the defined libraries using the Command Line and do anything using the command line, however the library does not appear in the Library workspace. The libraries in the FNAT ARE in the Library Workspace so it is the FUSER libraries which are not showing.

Are you using a remote NSC file for the PC security defs? We found that if the user had a Privil. Group(s) defined and the only link to the library was via one of these groups that the tree view did not show those libraries.
I haven’t tried this using a local NSC file, so this may not be the situation in your case since you tried NCSTDEMO (if you have it with People-protected … N). Aren’t these types of quirks fun!

Chad - I don’t have NSC on the PC so the only NSC file is on the Linux box.
From a LOT of trial and error I can see the library I initially logon to, but only if I myself have a special link - not linked via a group…
These quirks might be fun if there weren’t deadlines to meet :roll: !!!

AHA - I have finally found a difference - on the box I am having the problems with we installed NDV AFTER NSC - in the General Options:
“Activate Security for Development Server File” is missing. Does this mean we must reinstall Natural Security? And will reinstalling fix the problem if there is an existing Natural Security file?

Priscilla, I really recommend to call the techn. support, because there could be several reasons for your problem. But it seems, that your problem has something to do with the configuration and assignment of Fnat, Fsec, Fdev files. If “Activate Security for Development Server File” is missing in the options it seems, that wrong files were specified during installation of NDV.

Thanks Karlheinz, I have done that.

Hi Priscilla,

Have you found the problem / resolution to having your libraries show up?
Just curious, this could be one to file for future testing and troubleshooting.


Chad - this is driving me to drink… My NSC file now has the line that was missing. One of the environments on the problem box is now working just as it should - the other 3 are not. What have I done to fix this? Haven’t a clue. I have spent this morning trying to find a difference in NATPARMS, Adabas parms, Natural Security settings etc. between the environment that works and the ones that don’t. Each has it’s own database, FUSER and FDIC. The FSEC is common and the software installation is common. There HAS to be a difference somewhere, so what is it? When I find out I will post the answer here… :? The local SAG office is equally perplexed…