Mysterious Error - Possible X-Files entry? :D


is here someone who could give me a hint what’s Wrong with my SPoD? I use 6.1.1 PL 14 at Windows XP. A few days ago i played around with EntireX DCOM Modules (EntireX at my workstation. One day after this i started my SPoD normaly as i do it every day. Then i logged on to the Host (BS2000) and would start a Programm. Then i got the following Errormessages:

A Window with the Text:

Terminal Emulation:
Cannot start the communications server

(When i start with Strg+R out of the open Editor)
I got after this first Message an empty Terminal Emulation Window which i cannot close and i also cannot focus the Natural Window. (Seems like an Popup Window) I only could kill the Natural Session by killing the Process

(When i start with Commandline. Entering Programname)
I got after this first Message after klicking “Ok” another Error Message with the following Message Window:

Terminal Emulation not installed.

Next Window is:

Error - NAT0999 [BS2]
Communication error in TP-MAIN. Return code 12 received from TP-RDWRN during function ‘Peek NATRMT_OPERATION’

Communication error in TP-MAIN. Return code 12 received from TP-RDWRN during function ‘Peek NATRMT_OPERATION’.

Internal error.
Contact your Natural administrator.

If i start the same Programm two times again Natural will hang up and don’t answer to any input. The 3rd Start also writes a dump to the Hostside of SPoD (AFAIK NDS)…

The mysterious of this Error is that only on my PC i could reproduce this error on all other PC’s i get an Terminal Window with the correct return of the Natural Program.

A Testprogramm to reproduce this error is:
0010 PRINT ‘Hello World’
0020 END

I don’t know if there is someone who could gives me a hint to solve this Problem but i hope so :D. I already put this Error to Servline24 but the only solution i got was to install PL14 instead of PL13 that i used before where i already got this Problem.

If it’s the wrong Forum please write a PM to me.

Sascha Wiegandt

I’d recomment to try it with PL14, because your problem description exactly matches one which is solved with 611PL14.
Our internal problem reference number or that is SAGSIS P264008.

Here is a cutout of the problem description:
[color=“green”]Customer get a number problems with terminal emulation with NAt611 pl12.
(which they say did not happen before PL12)
For instance…

  1. Nat611 crashing
  2. nat611 hanging
  3. Message "Terminal emulation not installed "
  4. Nat0999 Communication error in TP-MAIN Return code 12 received from
    TP-RDWRN during function ‘Peek NATRMT_OPERATION’ [/color]

As i already wrote tha i use PL14 and could course the Natural Crash again. Sorry but i hoped that someone would have solved this Problem before me but as it seems i have to wait until my Official-request would be solved.

Sorry, your last sentence gave me the impression you are still on PL13 :oops:
You mention that you “played around with EntireX DCOM Modules”. And one day after you got that problem.
So did it work correctly with PL14 the day before?

If yes, did you mention this in your servline24 request? Because this could be a important information.

First i used PL13 and had no Problems with Terminal Emulations till i made some DCOM-Proxies for a new Project. The Day After i couldn’t start Programms in Terminal Emulation Mode so we opened a Request at Servline.

Answer was to install PL14 which i got 2 days later or so. I installed PL14 an still have the Problem since then.

So I’d strongly recommend to mention this in your servline request. I’m not an expert regarding the PC installation of the TE but I’d suppose that the cause of that problem can be found in the system registry.

At this point we should stop doing further problem analysis in that forum.

I would do that but SAG only would solve this Problem if we update to the next Natural Version on Host. :frowning: