Problem starting database

can somebody explain met the following error at startup of database:

INODSE5268

Failed to register server with XTS directory service

More info :

1. During the installation of Tamino 3.1.1.4 we had the following error message 'String variable is not large enough for string. Check the string declarations. (Error 401.)

2. During startup the following messages are given :

‘Failed to register server with XTS directory service : XTS0088E: XTS No CONNECT or LISTEN has been issued.’ (MessageID:INODSE5268)

Hi there,

What platform are you installing on? Was there already a Tamino install on the system?

Have you checked to see that there are entries in the hosts file for XTSDSHost and XTSDSPort?

What is in your XTSurl.cfg file?

Kind regards,

Simon

Hi,

We are using WIN2000. I’ll ask teh person to re-execute the installation and to verify the hosts file and the XTSurl.cfg file.

But the message '‘String variable is not large enough for string. Check the string declarations. (Error 401.)’ during install is something whcih can be related with the problem. I’ve looked in the installation log file, but I can’t see anything wrong in this file.

I’ve attached the logfile.
INO3114Inst.log (220 KB)

I’ve had a look thro the log file and I must admit that I cannot see anything that clearly relates to your string length error.

Of course the error is probably coming from an attempt to stuff something into the registry but what I do not know!

Lets hope that in good Microsoft honoured tradition a reinstall will resolve the problem!

Kind regards,

Simon

'Lets hope that in good Microsoft honoured tradition a reinstall will resolve the problem!'

Sorry, but this good Microsoft honoured tradition doesn’t help me this time. A reinstall gives the same.

Pity.

Maybe it is time to log a support request.

Kind regards,

Simon

Is there a standard way doing this?

If you have a valid maintenance contract you will be able to contact your local Software AG Customer Support Center by email or phone.

We have found the problem. The installation has added an incorrect " character at the end of the dirparms setting for XTS:

Incorrect value :

DirParms = “file=C:\Documents and Settings\All Users\Application Data\Software AG\xtsurl.cfg”"

Correct value :

DirParms = "file=C:\Documents and Settings\All Users\Application Data\Software AG\xtsurl.cfg"

You can change this by using the XTS tools.