Payload Not Getting Generated

Hello Everyone,
I’m working webMethod’s 6.5 EDI module. I’m facing one problem with EDIINT AS2 protocol. Here is the brief description of the problem:

MachineA

MyEnterprise.
MyEnterprise of MachineB as partner.
MachineB

MyEnterprise.
MyEnterprise of MachineA as partner.

MachineA sends an EDI [PO 850] to MachineB using wm.EDIINT.send and gets the user-status as: SendMsg:WAITMDN
MachineA receives EDI MDN with sender/receiver=unknown and user-status=ProcessMdnMsg.

On MachineB just one entry gets logged into TN’s Transaction Analysis. Which, says:
DocType: EDIINT
Identifies sender/receiver
Processing Status: Done
User Status: UNMATCHED

And when I open this transaction I don’t see any payload being extracted there. So, I think it is not firing the processing rule: “EDIINT Process Message”.

I’ve gone through WM pdf’s and this site even. And also implemented almost all suggested resolutions (e.g. reload EDIINT, EDIForTN packages etc). But all this was of no avail.

I would highly appreciate if some could help me out of the situation.

Did you makesure if the select option “Submit payload to TN” check box marked in the ISAdminConsole/EDIINT module homepage??Did you see any more errors in the Activity logs or system logs??

HTH,
RMG

I don’t think the fact that it doesn’t pick the processing rule is the problem. It’s the other way around: because the payload is not received, it cannot execute the processing rule. If the payload would have been transfered correctly, TN would have executed it.

I had a similar problem, and in my updating the DataDirect drivers to the latest version solved the problem. Which drivers are you using? What version?

Thanks, for the quick reply.

RMG:
The option “Submit Payload To TN” was already checked. I didn’t make any changes to that.

Hansvollebregt:
I didn’t have any distinct idea about this Data Drivers thing, before I saw your reply. So, wouldn’t be able to tell you. Could you tell me how to find the version number and possible errors that could come with this Data Drivers.

I’m working in different time zone (IST). So, perhaps wouldn’t be able to give a prompt reply.

Regards,
Manoj

Further to my above reply:
RMG:
I’ve sat debugging to Level 5 and then ran the service. It logged 3 entries in Service Log:

07-03-07 19:38:25 IST [ISU.0000.9999V1] New doc is a EDIINT [TRNSERV.000019.000001]
2007-03-07 19:38:25 IST [ISU.0000.9999C] Processing: NO MATCHING RULE; creating default rule [TRNSERV.000014.000026]
2007-03-07 19:38:25 IST [ISU.0000.9999D] Inserting doc m14e1m0024mbld9100000018 into datastore [TRNSERV.000016.000073]

I couldn’t make any sense out of these 3 entries.

Could any one please help me on the above said problem.

I think there is something wrong with my IS as I’m not even able to send EDI transactions using wm.EDIINT.send. Transaction getting logged with status UNMATCHED.:o

Any kind of help is highly appreciated.

Hello Everyone,
Thanks a lot for you support. There was a silly mistake and I missed out. Actually the EDIINT specific processing rules (i.e. EDIINT Process Message etc…) were not enabled by default. And I took it for granted that they were enabled.
So, enabling them solved the problem.

Regards,
Manoj

Manoj,

Sorry for getting back late,anyways glad to know that it is working…

PS:silly mistake happens…and always check check/troubleshooting etc…will help us in someway!!!:slight_smile:

HTH,
RMG