Not able to save Schema in wm61 developer

I have created a Schema using wm 6.1 developer, My flat file structure is fixed length positions. In one of the field in the schema I made changes to start position and end position. when I save it looks good, but when I refresh it the changes I made were disappearing. If any body have any clue, you are most welcome to give any suggestions.
Thank you in advance for you time

Which version of IS6.x are you using and seein this behaviour?

Its weird i haven’t seen this behaviour as we do lot of flatfile builds.

Just kill the developer session and try to change the same and login again…may be some memory leaks in the developer or session problems.
Just in dark.


Thank you so much for your quick response.
I am using Version 6.1 (132), I have already done the exercise you have mentioned in your message ( closing or killing developer session and re doing it). But still the same result. we are now working on Bringing down server and re doing again.

Tried the same exercise after re-starting the server we still have the same issue.

I got the same problem when using FF dictionnary and a FF schema associated. Informations in the dictionnary come prior to schema. So I think you have to make your changes to the dictionnary if you use one…

While working with flat files, don’t use “Save All” to save the schemas or dictionary. This would never save the schemas or dictionaries. Please use “Save” to save them and this works.

webMethods has a fix for this. I don't have the details right now. I can post the details tomorrow, but for now, follow the above mentioned step and you will be able to save your ff schemas and dictionaries.