Adding an N1 segment to the base schema

We are using webMethods 6.5 (I know…old).

Trying to set up a new 753 document (v. 4030) and the customer wants 2 N1 segments in the header (before the LX segment). When I generated the schema using “IS > wmEDI > Install TN Document Types” it created a single instance of the N1 segment (Document Reference rather than Document List). If you look at the “wm_img1.png” you’ll see that there is an option on the right to increase the max repeat (more than 1) but if I do this, the mapping fails when I try to add more than one address to this “list”.
Instead, I created the second N1 segment below this (wm_img2.png) and made it position 500, and recreated the “Document Type”.

In my mapping, I have created a flow service specifically for these 2 segments, and I send in the two single N1 segments, map data to them, and get the two N1 segments back to my EDI Record (see wm_img3.png).

My problem is, even though I map DIFFERENT data to both N1 segments, the data in both of them ends up being the same (the data from N1_B).

What can I do to fix this? There are NO errors returned. Just duplicate data.


Are you still on IS 6.5 version or it’s just wM Module 6.5 version running it on 7.x IS?

May be it’s a schema install issue or a wMEDI module6.5 fix needed and technically the dictionary/schema should show as N1 (document List) in the DT and can you try reinstall it again or fix the schema/doc type manually although this is not advisable?


All 6.5 I think.
There are two N1 segments in the schema (1 before the LX, and one after). The one before the LX is a single element, so I had to modify the schema manually (just changed max segments of the first N1 to “2” and recreated the document type…it worked fine).

As a note to anyone else, since I had already used (and initialized) the OLD DT in my maps, recreating the DT screwed things up in my mapping, which caused errors. When I started from scratch (FIRST modify the schema, create the new 753 DT, THEN start mapping) it worked fine.

Thanks :slight_smile:

OK what ever make sense and normally you shouldn’t touching the dictionary/schema for the loops (max repeat setting)…

This becomes challenging as you need to make a note and do the same on all other environments to be in sync.