Flat Files Schema on WM 6.1

Hello there,
I’m facing strange behavior on WM 6.1XX Flat File Schema.
Preveously, I made schema of a flat file that has a pattern like this :
[header] YO00000 + []// max repeat 1
[records]YO00001-YO99998 + [
]//max repeat unlimited
[trailer]YO99999 + [****]// max repeat 1
on WM ver 7.1
i made FF schema with a structure below :
record definitions | properties
YO00000 | max repeat 1
YO | max repeat unlimited
YO99999 | max repeat 1
whenever i run by convertToValues, the output is correct (all records definition is captured)

because our client is not yet implemented Ver. 7.1, so I tried to run the schema on ver 6.1 updated.
The result is differnt, [trailer] could not detected.
it’s included in [records] (‘YO’ record definitions) in the last row.
I’ve try many combinations instead of records defiinitions, the found some strange behaviors.
if the [trailer] is modified with YO9999 or YO9999901 (the testing trailer row is ‘YO99999012700’)
it produced correct output.
But, offcourse it couldn’t accepted.
Is ther any update of 6.1 version that fix my problem??
or is there any other way to solve this problem?

Best Regards,

Install the fix WmFlatFile_SP2_96 and try.

Thanks for the repply, but would you give me the information about that servicepack? is it included in Integration Server servicepack or Developer SP?

best regards,

Send an email to the webMethods support team asking the above service pack. Use your company email id to get a response. (It was there on advantage site sometime back, but its not available now). And its a patch onto the WmFlatFile package.


Send email to support@webmethods.com mentioning the service pack WmFlatFile_SP2_96 for the WmFlatFile Adapter,they will send it across or you can also open an incident request in the Advantage website.