NaturalONE CE install error

I downloaded the zip file and extracted it into my Desktop folder. When I run Setup, I get the following error, ‘The Natural Community Edition installation cannot be continued because the following file is missing: StartInstallation.bat’

But the file is there, under C:…\Desktop\DVD_Version_N1_8.3.5.0.242_CE\Windows

Can anyone please provide instructions on how to get the install completed.

Thank you.

Just a guess here, but did you also drop the DVD_Version_N1_8.3.5.0.242_CE.zip file on your desktop? If so you might have accidentally clicked on the Setup.exe from that folder. You have to run the Setup.exe from the permanent extracted directory or the scripts won’t be able to find the referenced directories and files.

It can be hard to tell them apart, especially if your explorer settings don’t allow the.zip file extension to display. You could try right-clicking on each to see if properties shows the extension. Or re-extract into a different directory.

I tried to install again today, still getting the same error. I made sure there is no copy of the zip file in my desktop and that I am running the Setup.exe file.

Hi Jojo,

I’m sorry, but I believe you are still trying to install directly from the .zip folder.

I found a spare machine running Windows 10 and saved a copy of the downloaded DVD_Version_N1_8.3.5.0.242_CE.zip file to the desktop. When I right clicked on it and selected Open (with Explorer), moved down to the next lower directory and executed the Setup.exe file there, I eventually got the same error message you did.

However, when I right clicked on the downloaded file and selected Extract, and then created a new permanent directory where the extracted files were created, I was able to successfully run the Setup.exe in that directory which successfully completed the installation.

Note when you run the Extract, you can change the name of the top directory you are creating so you can tell them apart, or put the extracted files in a completely different directory, like under Documents, or I like to use the Downloads directory under Documents. Also to check if you are using the .zip file or not, you can right click on it and select Properties. For the .zip file the 2nd line of the Properties display shows “Type of file: Compressed (zipped) folder (.zip)” The Properties for the new extracted directory will show “Type: File folder (.242_CE)”

Another tip, once you have created the extracted directory, and before running the Setup, click on the ReadmeFirst file, read or print it out, and keep following the links to Getting Started, Next “Installation”, Next “Starting NaturalONE for the First Time”.

Hope that helps. Good luck.
George

Hi George,

Thank you for all your help on this.

I did like you described on your last reply, and tried to install on another machine (my personal laptop), and it worked!

I then erased anything NaturalOne on my work laptop, did the download/extract/install, just like what I did in my personal laptop. As luck would have it, I still get the error. My guess now is that it has something to do with the office laptop install privileges. I would have to reach out to the company tech support and see if they can help me.

Again, thanks for your help.

Jojo

You’re welcome, Jojo. Glad you were able to get NatONE installed on your home laptop. Good luck getting help from tech support for the work laptop.

I didn’t think about install permissions, although on my home Win 10 Pro system I did have to answer yes to the User Account Control popup to allow the system modification. I would have expected a different error message from the Setup installer if you weren’t allowed to install. Always learning something new.

Have fun learning NaturalONE. I’m finding the Eclipse environment a real trip after a whole career of 24 x 80 green screen terminals.

George

Hi George,

I did not think about the install permissions as well, until I tried it on my personal machine. By default, no one is allowed to install anything on their work machine. In my case, I was granted ‘elevated’ access to install NaturalOne. I am guessing it is not the same as ‘full administrator’ access, which is why I am able to start Setup.exe, but it’s not able to proceed with the install.

Jojo