Failed to synchronize with internal Tomcat server

Downloaded NaturalONE Community addition and after running SAG Designer got “Failed to synchronize with internal Tomcat server”[b]

thanks for your assistance



I think the line above the “Failed to synchronize” message indicates the problem, “ERROR: Cannot start server. Server instance is not configured.” The Tomcat server is supposed to get set up the first time you start NaturalONE Designer. I don’t know how to do it afterwards, so if you haven’t already done so, I think you should uninstall NaturalONE and reinstall it following all the instructions starting with the ReadMeFirst.htm page under the unzipped DVD… install directory, especially the page on “Starting NaturalONE the first time”, at DVD_Version_N1_8. As it explains, you need to wait until the Tomcat server finishes initializing before doing anything else in NaturalONE, like installing the Sample Apps.

Some other thoughts: Be on the lookout for pop-up messages from Windows about allowing the programs to update your system, and possible blocks by your firewall if you have one installed. Sometimes they hide behind the other open windows.

Are you installing on your personal computer with an administrator user id, or on a work machine with a non-admin user id? If a work machine, you might need to get your tech support to install it. Is it possible that another instance of Tomcat is on the machine for some other use?

When you do the uninstall, it’s a good idea to check to make sure everything is removed, especially Adabas directories and data files under C:\Natural-CE and C:\Program Data\Software Ag. The uninstall doesn’t always do a complete job. The re-install will check and refuse to install if it finds any remnants. You might have to use regedit to search through the registry and delete any entries for Software Ag.

Hope that helps. Good luck!

Hi George,

I started from scratch, followed the uninstall/install instruction and your other recommended suggestions + REGEDIT and it WORKED.

Your assistance is greatly appreciated



I’m happy to hear that worked for you. Hope you can now have lot’s of fun with NaturalONE!


One additional hint: In this situation it is usually sufficient to start with a fresh (empty) Eclipse workspace instead of reinstalling NaturalONE.