Natural One can't use Construct Generation

Hi, I have a problem using Natural One construct generation.
I didn’t find anything helpful around, maybe here someone can help me.

Thanks!

Product/components used and version/fix level:

image

Explanation of the problem:

Whenever I try to interact with construct generation in Natural One (create, regenerate, add construct to local project ecc.) I always got the same error: NAT7301 Invalid LFILE assignment.

Error messages: 1st adding construct runtime to project, 2nd generating a new object

[11:12:27.162][ERROR][DefaultHandler] Error adding Construct resources to an existing project.
com.softwareag.naturalone.natural.paltransactions.external.PalResultException: CSOFLIST 5340 NAT7301 Invalid LFILE assignment.
	at com.softwareag.naturalone.natural.paltransactions.internal.PalTransactions.getResultException(Unknown Source) ~[com.softwareag.naturalone.natural.ndvserveraccess_9.2.1.0000-0304.jar:?]
	at com.softwareag.naturalone.natural.paltransactions.internal.PalTransactions.utilityBufferReceive(Unknown Source) ~[com.softwareag.naturalone.natural.ndvserveraccess_9.2.1.0000-0304.jar:?]
	at com.softwareag.naturalone.natural.common.server.internal.NaturalServer.utilityBufferReceive(Unknown Source) ~[com.softwareag.naturalone.natural.common_9.2.1.0000-0304/:?]
	at com.softwareag.naturalone.gen.cst.core.server.generator.NaturalCallnatInterface.callServer(Unknown Source) ~[csteclipse.jar:?]
	at com.softwareag.naturalone.gen.cst.core.server.generator.NaturalCallnatInterface.callNat(Unknown Source) ~[csteclipse.jar:?]
	at com.softwareag.naturalone.gen.cst.core.server.services.NaturalService.issueCall(Unknown Source) ~[csteclipse.jar:?]
	at com.softwareag.naturalone.gen.cst.core.server.services.CodeFrameListService.list(Unknown Source) ~[csteclipse.jar:?]
	at com.softwareag.naturalone.gen.cst.eclipse.utils.ServerUtils.getCodeFrames(Unknown Source) ~[csteclipse.jar:?]
	at com.softwareag.naturalone.gen.cst.eclipse.views.serverview.AddToExistingProjectContext.addCodeFrames(Unknown Source) ~[csteclipse.jar:?]
	at com.softwareag.naturalone.gen.cst.eclipse.views.serverview.AddToExistingProjectContext.addAll(Unknown Source) ~[csteclipse.jar:?]
	at com.softwareag.naturalone.gen.cst.eclipse.views.serverview.AddToExistingProjectContext.doProcessSelectedNode(Unknown Source) ~[csteclipse.jar:?]
	at com.softwareag.naturalone.gen.cst.eclipse.views.serverview.AbstractContext.processSelectedNode(Unknown Source) ~[csteclipse.jar:?]
	at com.softwareag.naturalone.gen.cst.eclipse.jobs.AddToExistingProjectJob.runInWorkspace(Unknown Source) [csteclipse.jar:?]
	at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:42) [org.eclipse.core.resources_3.14.0.v20210215-0934.jar:?]
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63) [org.eclipse.core.jobs_3.10.1100.v20210111-0815.jar:?]
[11:16:44.274][ERROR][InvocationTargetExceptionHandler] Error initializing model specification: 
java.lang.reflect.InvocationTargetException:  CSUCTRL 0840 NAT7301 Invalid LFILE assignment.
	at com.softwareag.naturalone.gen.cst.eclipse.client.framework.internal.wizard.CSTWizard$1.run(Unknown Source) ~[?:?]
	at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122) ~[?:?]
Caused by: com.softwareag.naturalone.natural.paltransactions.external.PalResultException:  CSUCTRL 0840 NAT7301 Invalid LFILE assignment.
	at com.softwareag.naturalone.natural.paltransactions.internal.PalTransactions.getResultException(Unknown Source) ~[?:?]
	at com.softwareag.naturalone.natural.paltransactions.internal.PalTransactions.utilityBufferReceive(Unknown Source) ~[?:?]
	at com.softwareag.naturalone.natural.common.server.internal.NaturalServer.utilityBufferReceive(Unknown Source) ~[?:?]
	at com.softwareag.naturalone.gen.cst.core.server.generator.NaturalCallnatInterface.callServer(Unknown Source) ~[?:?]
	at com.softwareag.naturalone.gen.cst.core.server.generator.NaturalCallnatInterface.callNat(Unknown Source) ~[?:?]
	at com.softwareag.naturalone.gen.cst.core.server.generator.ModelClearInterface.callClearSubpOnServer(Unknown Source) ~[?:?]
	at com.softwareag.naturalone.gen.cst.core.server.generator.ModelClearInterface.invokeClear(Unknown Source) ~[?:?]
	... 2 more

Show us the steps you take to generate or regenerate a module using Construct.

What platform and version is your Natural runtime?

Hi,

Natural 8.4.1 on Unix

(1st step)

(2nd step) after I select the module in 1st step
image

Error message

java.lang.reflect.InvocationTargetException: CSUCTRL 0840 NAT7301 Invalid LFILE assignment.
at com.softwareag.naturalone.gen.cst.eclipse.client.framework.internal.wizard.CSTWizard$1.run(Unknown Source)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)
Caused by: com.softwareag.naturalone.natural.paltransactions.external.PalResultException: CSUCTRL 0840 NAT7301 Invalid LFILE assignment.
at com.softwareag.naturalone.natural.paltransactions.internal.PalTransactions.getResultException(Unknown Source)
at com.softwareag.naturalone.natural.paltransactions.internal.PalTransactions.utilityBufferReceive(Unknown Source)
at com.softwareag.naturalone.natural.common.server.internal.NaturalServer.utilityBufferReceive(Unknown Source)
at com.softwareag.naturalone.gen.cst.core.server.generator.NaturalCallnatInterface.callServer(Unknown Source)
at com.softwareag.naturalone.gen.cst.core.server.generator.NaturalCallnatInterface.callNat(Unknown Source)
at com.softwareag.naturalone.gen.cst.core.server.generator.ModelClearInterface.callClearSubpOnServer(Unknown Source)
at com.softwareag.naturalone.gen.cst.core.server.generator.ModelClearInterface.invokeClear(Unknown Source)
… 2 more

(3rd step) after ignoring the error
I fill the fields with correct data, as I would do in NCSTG via ssh ndv.

(4th step) after pressing FINISH button.
image

Same thing with every module I try to generate

what parameters are you passing to the NDV server? If you login to the host Natural terminal session and use SYSFILE command, what LFILE assignments do you see? Add those LFILE’s to your parameters when connecting to NDV (Server Mapping Properties) and see if that resolves the problem. If it does, ask your Natural administrator to include the LFILE parameters in the natparm module being used by NDV.

Hello,

Didn’t resolved anything by me.
I told my Administrator about this Lfile problem and he edited my natparm config file, now it works fine.

Thank you!!