Natural on Windows 3148

I am a LONG time (read old) Natural/Adabas developer. In my day, I was up on Natural techniques and Adabas functions. Unfortunately, it has been a very long time since I coded anything. In an effort to “get back in the game”, I have downloaded the Community edition of Natural and Adabas. I started the “demo” database (DBID 12) using the DBA Workbench. But when I try to READ any of the files, I get the error code NAT3148 – database 12 not active! The workbench shows the database Active. The Windows Task Manager shows Adabas.exe and adanuc.exe both running. What am I doing wrong?

Glenn Russell

I’m a little surprised that you’re having trouble with this. The connection from Natural to Adabas should be automatic. Both are running on the same machine, correct?

Yes, Ralph, both Natural 6.3 and Adabas V6.3.0.03 are running on my HP laptop using Windows 7. The Adabas Workbench seems to see it fine but not Natural. Natural programs seem to run fine except for the database access.

When started, it does say that it started without the PLOG because of it being a demo DB

The PLOG is not involved.

I don’t believe there have been many installation issues with the Community editions, but most occurrences I have seen have involved HP hardware.

Unfortunately, HP is the hardware I have. Guess I’ll just keep whacking it with a bigger hammer. Thanks anyway.

P.S. Is there much traffic on this site - is it worth monitoring?

Glenn

Start Natural and the demo database and let us know what Software AG services are running. They should all be active, as their Startup Type should be set to Automatic.

Ralph, you’re a genius! I reinstalled Natural and Adabas 3 more times (using a much bigger hammer each time) and magically it now works. When I look thru the Task Manager, I see adabas.exe(64 bit), adadba.exe(32 bit) and adanuc.exe 64 bit) plus natural.exe *32bit and nderun.exe *32. All of these are same as before.

I dunno what I did wrong before or right this time but as long as it’s working, I’m a very happy camper. Now let’s see how much of this stuff I can get my old grey bearded brain to remember.

Thank you for you efforts and Happy Thanksgiving!

Glenn

I don’t think the problem was related to what you see in Task Manager. I believe it was your services.

Click Start, right-click Computer, click Manage, open Services and Applications, click Services. Then scroll down to Software AG and report here what you see for Adabas.

I suspect that your Adabas services were not starting properly.

OK Ralph, here is what I see:

SoftwareAG Adabas 6.3.0.03 client SHM service
" Adabas Database Service
" Natural 6.3 Buffer Pool Service

That’s all I see - any help?

Glenn

I AM FACING SAME PROBLEM CAN ANY ONE HELP?

possibly mratunjay, but you’ll need to supply some details about what problem you are facing. If you have the same problem, have you followed the steps offered already? Ralph provided some items to look for (Windows Services, are they started?). Glenn did some uninstall and reinstall to get his environment working. Have you tried that?

Please let us know after you find your caps lock key…all caps suggests shouting and is considered impolite on forums.

Hi,

I am pretty new to Adabas Natural and I am facing the same issue with the community edition of Natural Adabas.

Here are a few details:

  1. I am using the Windows version 7, on a Dell Laptop.
  2. As Ralf had mentioned I checked the services. Following are the services running:
    “Software AG Adabas 6.3.0.03 Client SHM Service” - Status started - Start Type Automatic
    “Software AG Adabas database Service V63003” - Status started - Start Type Automatic
    “Software AG Natural 6.3 Buffer Pool Service” - Status started - Start Type Automatic

I even have tried to re-install Adabas but have not found any luck. I am not convinced about this working but I’ll try to give it a couple more tries.

Any help on this is very much appreciated!

Thanks,
Nitesh Jain

Magically the re-installation for the third time worked!

I just had un-installed/removed the previous version and re-installed the adabas with the same exe. Then I restarted the system and it worked!

Thanks Glenn, Ralf and every one for the forum!

I have downloaded and installed Natural Community v6390 on my windows 7 kvm, but I cannot start any ADABAS, including the SAG-DEMO-DATABASE. There is no option on my start/programs to start ADABAS. I have tried reinstalling but having the same problem. Anybody know what is happening?

Thanks
Jose

The Community edition expects you to be the DBA, so there is no database “start” function provided from the Start menu nor the task bar. But the Start menu should contain an entry called Software AG Adabas, and within that, Adabas DBA Workbench. Invoke the workbench, highlight the database name, and press ctrl-s (or, on the menu bar, click Database --> Start).

If the Adabas entry is missing from Start, go to the installation directory. In my case, it’s

c:\Program Files\Software AG\Adabas\V63201\BIN

From there, invoke startdba.cmd.

The is only one Folder inside my Software AG folder, and it is named Natural. No ADABAS folders or files inside. :frowning:

You need Adabas Community Edition. This is a separate download and installation.