Community Editions of Adabas and Natural for Windows

I have downloaded Community Editions of Adabas and Natural for Windows. I have versions ADABAS 3.3.1 and NATURAL 6.1.1 already installed and am having problems removing them before installing the new downloaded versions.

After running the REMOVE program routine for ADABAS 3.3.1 and then the new setup, the ADABAS installation is telling me that it is already installed. It is possible that the removal routine of the older versions is not working, and assume the same is for NATURAL as well.

I would like some help removing the old version as the Windows ADD/ REMOVE programs route dos not seem to work for me. Running on XP SP2

Regards
Chris

Look in the registry under HKEY_LOCAL_MACHINE\SOFTWARE\Software AG; here you will find entries corresponding to the versions of the Software AG products you have installed. If you are sure that you have removed / uninstalled the product, you can probably also delete the corresponding registry entry for that product as well.

Stephen, thanks for that my problem has been resolved, and I have been able to install ADABAS 5.1.5. but I got an installation error telling me the demo database could not be created

When I attempt to start up the DBA Workbench I get a System Error message box with message

Could not access c:\Program Files\Software AG\Adabas\etc\ADABAS.INI

and the program fails to execute.

Can you provide some help on this for me please

Regards

Chris

First a stupid question: Is the file actually there? If it is not then have a look in C:\Program Files\Software AG\Adabas\V515\BIN\AEO and copy the ADABAS.INI file to the above location.

Not a stupid question at all,it wasn’t there but was in the location you have suggested. Copying that has solved the problem.

Now if we could only have Predict on this platform, life would be easier

Regards

Chris

Predict is available “on this platform”, but not as a community edition, afaik.

Just downloaded ADABAS 5.1 and NATURAL 6.2, both for Windows XP.
After installing ADABAS, I received the message that the DEMO DB as not installed and I should look into the README.TXT for instructions.
Did not find any help in there…
Whats next?
Regarding NATURAL, can I go ahead and try to install it?

Thanks

Yes. The Adabas and Natural installations are independent. The products can be installed in either order.

Thanks Ralph.

I still have this problem:

“After installing ADABAS, I received the message that the DEMO DB as not installed and I should look into the README.TXT for instructions.
Did not find any help in there…”

Can you help?

I haven’t tried the Community Edition, but I presume that the installation wizard is similar to that of the General Availability version. The GA version typically has an option to load the demo database, but the default setting has flip-flopped from release to release - sometimes the default is to load the database, sometimes not. In one recent version, we had no option but to load the demo DB manually.

First, try re-running the installation in update mode, if such an option exists. Look for an option to load the demo database.

If that doesn’t work, take a look at the Adabas Installation Guide. If it’s not available in the Community Edition, use the on-line documentation available from the Forum.

http://techcommunity.softwareag.com/ecosystem/documentation/adabas/ada514unw/utils/apxa.htm

It refers to %ADADIR%%ADAVERS%\demodb\loadall.bat. Is this .bat script available in the Community Edition?

I found this directory:

C:\Program Files\Software AG\Adabas\V515\BIN\demodb and module LOADALL.BAT, but if I try to run it using MS-DOS, I get this message:

“C:\Program Files\Software AG\Adabas\db001\assign.bat does not exist”

What I am missing??? :frowning:

Ok, I started the DBA Workbench, which some how created the assign.bat module and later was able to run the loadall.bat.

Now when I try to start the DB, I get this message:

%ADANUC-I-STARTED, 13-JUL-2007 11:55:40, Version 5.1.5.01(01) (Windows)
%ADANUC-I-PARSET, setting of ADABAS_ACCESS=ALL
%ADANUC-I-PARSET, setting of AR_CONFLICT=(ABORT)
%ADANUC-I-PARSET, setting of BI=
%ADANUC-I-PARSET, setting of DBID=1
%ADANUC-I-PARSET, setting of LAB=819200
%ADANUC-I-PARSET, setting of LBP=16M
%ADANUC-I-PARSET, setting of LPXA=10
%ADANUC-I-PARSET, setting of LWP=1000000
%ADANUC-I-PARSET, setting of MGC=50
%ADANUC-I-PARSET, setting of NCL=50
%ADANUC-I-PARSET, setting of NISNHQ=100
%ADANUC-I-PARSET, setting of NT=3
%ADANUC-I-PARSET, setting of NU=20
%ADANUC-I-PARSET, setting of PLOG=
%ADANUC-I-PARSET, setting of TNAA=3000
%ADANUC-I-PARSET, setting of TNAE=3000
%ADANUC-I-PARSET, setting of TNAX=3000
%ADANUC-I-PARSET, setting of TT=3000
%ADANUC-I-PARSET, setting of WRITE_LIMIT=0

%ADANUC-F-PLOGLIC, Parameter PLOG not allowed by licensing
%ADANUC-I-IOCNT, 2 IOs on dataset ASSO
%ADANUC-I-ABORTED, 13-JUL-2007 11:55:40, elapsed time: 00:00:00

Which parms do I have to set up, where and how?

Thanks :oops:

From the DBA Workbench
. highlight the demo database
. click on Profile
. click on Nucleus Parameters…
. uncheck the PLOG parameter
. click on SAVE
. start the database

Without a protection log, it’s unlikely that you’ll use Adabas in a production environment. It is a Community Edition, after all.

Worked as you explained, thanks.
Now I see:

DBID 1
Name DEFAULT-DATABASE
Status Active
Version 5.1

When I go to NATURAL and try to run a pgm to read EMPLOYEES
I get a NAT3148 Database 12 is not active…
If I list the DDM EMPLOYEES on NATURAL, I see DBID 0 and File number 11, but if I go to DBA Workbench, double-click on the DB above,
I see the list of files and EMPLOYEES shows as file number 9…

This is getting most frustrating than I thought…

Actually you should have TWO employees files,
EMPLOYEES as file # 9
EMPLOYEES-NAT as file # 11

As for DBID 12 being targeted from Natural, check the UDB parm.

I saw that Wolfgang, thanks.

Now, where do I change the UDB parm? On DBA Workbench on Natural?
Should be from what to what?

Since you have only a single database at present, I suggest that you set it as your default.

. Start
. All Programs
. Software AG Natural 6.2
. Configuration Utility
. Natural Parameter Files
. NATPARM (or create a new profile)
. Database Management
. User DBMS Assignment
. set the UDB parameter to 1 (your DBID)
. save the changes
. exit the configuration utility
. start Natural

Bingo! Easy when you know it, right? 8)

I am missing my icons on the desktop and forgot about the different ways to start/change things since I played with Nat LightStorm…(Few moons ago…).

Thanks for your help and patience.