Uninstall Adabas - Windows 10

I’m now trying to install NaturalOne on Windows 10.

A while ago I had Adabas installed, but had thought it had been removed.
There are no libraries related to SoftwareAG (apart from the new install ones), and no services running that look like anything related.

But I am getting the message “The NaturalONE Community Edition can only be installed on a PC without an Adabas installation. Please uninstall Adabas 6.3 or deactivate Adabas 6.4 and start the installation again.”

Where should I be looking?

Did you check c:\ProgramData\Software AG\Adabas?

Had to deal with this once, long ago. I think I had to scan the registry for Software AG, SAG, and Adabas entries.

Thanks, nothing there.

I have tried this command in Powershell:
Get-ItemProperty HKLM:\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall* | Select-Object DisplayName, DisplayVersion, Publisher, InstallDate | Format-Table –AutoSize

and that shows in the installed aplications:
Software AG Products: C:\Natural-CE
But I can’t see that anywhere else

I think your problem is an incomplete install of Adabas. Did you scan the entire registry for those 3 keywords and delete all entries related to Adabas?

Thank you

I used regedit to find the "Software AG Products: C:\Natural-CE " items and delete them. They now no longer show.
I also searched in regedit for softwareag, adabas and natural and removed anything that looked related.
I have restarted, but I’m still getting the same problem

Check for SAG-related Windows services.
Start --> Computer Management --> Services and Applications --> Services

If there are no Adabas services running, or after you stop them if the install still won’t work, I had one other thought.

When you said you found nothing there when you checked Ralph’s first suggestion, c:\ProgramData\Software AG\Adabas, were you able to see the c:\ProgramData\ directory and all of its subdirectories? I think that top directory was originally hidden on my Win 10 laptop until I went into the folder settings and selected “Show hidden files, folders and drives.”

Good luck!

I’ve reset my laptop to factory settings, which has solved the problem, but is a bit extreme