MWS installation - should it be this hard?

I’m tearing my hair out trying to get MWS working.

Does everyone go through this, or is it usually straightforward?

I installed using the WM installer and the GUI DB configurator.
Since it’s failed, I’ve reinstalled several times, using the WM installer’s reinstall option. I’ve also dropped and recreated the tables several times, using the GUI DB configurator.

Everything appears to work, until I start MWS.

Depending on the order I do things, I get different errors.

Currently - just after recreating tables - I get:

(Framework : FATAL) - [POP.005.0026] Must have at least one server node defined

Just after a fresh install, I get:

2009-03-09 17:28:25 CET (dataAccess : WARN) - getXTypeID Failed on wm_xt_installcomponentdata
2009-03-09 17:28:26 CET (Framework : INFO) - No registered exception delegate
2009-03-09 17:28:26 CET (Framework : FATAL) - [POP.003.0137] Unable to create with unknown type: "0".
com.webmethods.portal.PortalException: [POP.003.0137] Unable to create with unknown type: "0".
        at com.webmethods.portal.mech.storage.impl.ContainerMechanics.createChild(ContainerMechanics.java:1079)
        at com.webmethods.portal.mech.install.impl.BasicInstallMechanics.registerComponent(BasicInstallMechanics.java:593)

In other circumstances I can’t put my finger on, I’ve seen NullPointerException and ClassCastException.

All I want to do is look at my Broker queues. Is there a simpler way?

Shouldn’t be that hard, i had issues the 1st time but like any other wM component its simply straightforward if we follow the installation guide.

As you mentioned you reinstalled more than once, something should have messed up, try installing on a different port this time. Also, i’d suggest creating a new Database(schema) this time.

Hope this helps.

S

OK, what I’ve done now is:

  • used the DB configurator GUI to drop tables for database component ‘Product - My WebMethods Server’
  • used the same procedure to drop tables for database component ‘MyWebMethodsServer’ (aside: what is the difference between these two?)
  • Launched the installer, chose the reinstall option from the advanced panels
  • Selected MyWebMethods Server, and MyWebMethods User Interfaces (all of them)
  • Incremented the port number by one, as you suggested.
  • Navigated to the installation stage

I’m currently waiting for the download to complete. This usually takes well over an hour, so you can see how I’d like to retry this as few times as possible.

The installation guide is not at all clear as to what I should do next. It explains how to run the DB configurator, but it does not explain when it is appropriate to do so.

  • Since I gave the installer GUI DB connection parameters, will it automatically create all the necessary tables?
  • Which DB component create script should I run? ‘Product - MyWebMethods Server’, ‘MyWebmethodsServer’, or both? Does order matter?

No use.

I tried starting MWS without running the DB configurator, and it failed to start (“No schema defined”). That seems fair enough.

I created the tables using the configurator, and it started initializing components.

2009-03-10 14:30:50 CET (Framework : INFO) - Initializing components of: bootstrap
2009-03-10 14:43:32 CET (Framework : INFO) - No registered exception delegate
2009-03-10 14:43:32 CET (install : WARN) - Trying to recover by uninstalling failed component: wm_bootstrap.dccb
2009-03-10 14:43:32 CET (Framework : FATAL) - [POP.004.0102] Script file not found: config:/deploy.dccb.xml
com.webmethods.portal.PortalException: [POP.004.0102] Script file not found: config:/deploy.dccb.xml
        at com.webmethods.portal.service.install.impl.ant.AntRunner.init(AntRunner.java:143)
(trimmed out remainder of stack trace)
2009-03-10 14:43:32 CET (Framework : INFO) - Shutting down PortalServlet

Note the 13 minute pause before the bootstrap failure.

Any clues as to what to try next?

ukslim,

I think, there is no difference between the component ‘MywebMethodsServer’ and PRODUCT-MywebMethodsServer. i checked the installation scripts they both create the required db tables for MWS( I used PRODUCT-MywebMethodsServer). you can check the results in webMethods7\common\db\logs. I suggest you use only one of them.

You should always run these scripts before u start the MWS for the first time. General order is complete the installation and then complete the db tasks, make any config changes if necessary and start the server.

Hope everything will run fine this time, usually the MWS takes very long time to start for the first time. make sure u follow the logs and see what is happening.

Thanks,

S

Something with your installtion, i guess

deploy.dccb.xml, is located in \webMethods7\MWS\server\default\temp check if u have this on ur system.

S

There’s a bunch of stuff in /webMethods7/MWS/server/default/temp - but no deploy.dccb.xml there or in any subdirectory. Any idea what was supposed to put it there?

As i check the time stamps on my system, the file is created by the Installation.

Hmm, so if the installer is expected to put something there, yet it’s not doing so, what can I try next?

There’s ample room on the filesystem, and I’ve been running the installer as root.

Can u try deleting the default MWS instance and create a new instance?

Not sure what is wrong with ur installation, i am suggesting a trial.

You may have to manuallly update the url, user id and passworkd in the db.xml file?

Go to your “/webMethods7/MWS/server/default/” directory and update the db.xml file. Also in our initial install the url had a missing semicolon prior to the // which prevented the service from starting.

You will also need to update the DB pools in the associated IS prior to using MWS for the first time.

add the mws pool alias then setup the associated functional aliases.
mws will need the ProcessAudit, IScoreAudit and ProcessEngine aliases pointed to your mwsdb pool.

This is what you might have done during installation… But just have a quick look…

Install My webMethods Server instance in default port 8585. If you have it already installed, uninstall it and do a fresh installation of MWS. Do not try to reinstall on the same instance or files again as it is giving more problem for you now…

Provide the Database information…

If you have database already installed, provide the exact SID instance name. DB Configurator will take care of creating the User… So just specify the username and password - Administrator/manage

Remember, at this point, you dont need to have the Oracle instance actually created/running, you dont really need to have the SID existig as well as you dont really need to have the Database user and password already created…

Optionally, you can select Process Engine, Monitor under Integration Server if you want to execute BPM

MWS instance installed successfully now…

If you start DB installation after webMethods installation, create the database instance with the same name with what you have supplied during webMethods installation.

In DB Configurator wizard, select

Type: create
Database Component: ALL
version: latest

RDBMS: Oracle
URL: what you have provided before
User ID: what you have provided before (Administrator in this case)
Password: manage

As this user is not existing already, select Create Tablespaces and Database User by providing the Admin id: system/password
Tablespace directory: oradata path… upto \oradata

All tables would have created successfully.

Now, the user is created as well as all scripts have run successfully… You can check the db information in webMethods7\MWS\server\default\mws.db.xml

in 71, db.xml
in 712, mws.db.xml

password would have been encrypted here… doesnt matter…

start MWS now… and lets see how it goes…

Thanks for everyone’s help.

I deleted the MWS directory - rm -rf IntegrationServer/MWS

I created an image, having finally decided that I was likely to be retrying the install several times.

Dropped DB tables, installed from image, created DB tables, ran mws.sh: got errors

Deleted MWS directory again.

Dropped DB tables, installed from image, created DB tables, ran mws.sh: started up successfully!

My webMethods Server "default" Node "localhost.localdomain-node42175" took 45,120 seconds to inititalize

Is it normal for MWS to take 12 hours to initialise first time? I’m scared to stop it in case it takes the same amount of time next time. And for HTTP requests to take 10 seconds to respond? This is running on VMWare with 2GB of RAM assigned to the VM. /proc/meminfo does not indicate a memory shortage. Filesystems are at 75% usage.

No… It shouldn’t take 12 hours to start… Even i have it installed in my desktop with 1 GB RAM, where it takes maximum 10 mins to start… I have Oracle, IS installed in the same machine…

12 Hours is not good. The default jvm memory settings for MWS are very low. I would try to set them as high as you possibly can by changing the settings in server.properties.sh located in the MWS/server/default/bin directory under you webmethods installation directory…

At the very least I’d set Xms and Xmx to a 1gig if you can.

How is ur MWS doing, everything fixed??

Hi Guys,

I just faced the same issue yesterday with one of my instances. The problem is that due to repeated changes in username and passwords on the database which you would be effecting on the MWS\config\default\config\mws.db tends to be pretty volatile.

Many a times we just do a Ctrl+C on the WMS server window to close the server which is not at all advisable and is the root cause for this issue as when the MWS shuts down it is supposed to do a series of operations including service unloading which get messed up. So a service gets turnedoff without unloading in your case the register node service.

To get through this all you need to do is go back to your installer and re-configure the MWS on the same location where it was installed earlier. It would just re-create the new instance and overwrite the files. Takes about 5 minutes to do so. Please ensure that after that you RESTART the whole machine and then run the WMS server. Also ensure that you always SHUTDOWN the server from the start->wm712->servers->shutdown-> My webMethods Server XX.

Hope this helps…

regards,
sam…

Guys see this:

Had the same problem fixed it!

Credits:

http://tech.forums.softwareag.com/techjforum/posts/list/24129.page

hi first create mws server instance(default or your own instance )