My WebMethods Login Page disappear

Hello:

I need help because the login page for mws disappear. After executing http://mws:8585, the page goes blank, I mean, the user and password box is not displayed.

thanks in advance.

best regards.

Is this the correct URL for your MWS server :wink: looks little funny that u have hostname as MWS :stuck_out_tongue: … however after starting your MWS … check the MWS logs to see what’s the exact URL and port on which MWS has started and try to open that in browser…

The url is correct. Sorry the url is http://buadaix001:8585/

did u checked MWS logs… you can find logs @ MWS\server\default\logs … check if MWS is up and running… FYI hope u know that MWS require DB connection to run…

Here is _problem.log,

2011-02-22 11:54:09 ARST (Framework:WARN) - com.webmethods.portal.portlet.wm_migrationx.bizPolicy.command.ExportRoleFunctionalPrivilege
2011-02-22 11:54:09 ARST (Framework:WARN) - Unable to initialize Component: exportrolefunctionalprivilege_wm_migration Null class returned
2011-02-22 11:54:15 ARST (webservice:WARN) - SOAPException( Server: Service temporarily unavailable. )
2011-02-22 11:54:15 ARST (webservice:WARN) - SOAPException( Server: Service temporarily unavailable. )
2011-02-22 11:54:24 ARST (webservice:WARN) - docbase unable to locate file system/application.xml
2011-02-22 11:54:24 ARST (webservice:WARN) - docbase unable to locate file system/console.xml
2011-02-22 11:54:24 ARST (webservice:WARN) - docbase unable to locate file system/jndi.xml
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, ‘ConfigureLoggers/’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, 'ConfigureLoggers/
’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, ‘ConfigureLoggers/’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, 'ConfigureLoggers/
’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, ‘ConfigureLoggers/’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, 'ConfigureLoggers/
’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, ‘ConfigureLoggers/’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, 'ConfigureLoggers/
’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, ‘ConfigureLoggers/’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, 'ConfigureLoggers/
’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, ‘ConfigureLoggers/’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, 'ConfigureLoggers/
’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, ‘ConfigureLoggers/’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, 'ConfigureLoggers/
’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, ‘ConfigureLoggers/’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, 'LogServerSelector/
’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1058: The resource referred to by to-view-id, ‘LogServerSelector/view.view’, for navigation from ‘/LogServerSelector/’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, 'LogViewer/
’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:25 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1058: The resource referred to by to-view-id, ‘LogViewer/view.view’, for navigation from ‘/LogViewer/’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:28 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, 'PoolConfigPortlet/
’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:28 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, ‘PoolConfigPortlet/’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:28 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, 'PoolConfigPortlet/
’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:28 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, ‘PoolConfigPortlet/’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:28 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, 'AliasConfigPortlet/
’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:28 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, ‘AliasConfigPortlet/’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:29 ARST (webservice:WARN) - docbase unable to locate file system/application.xml
2011-02-22 11:54:29 ARST (webservice:WARN) - docbase unable to locate file system/console.xml
2011-02-22 11:54:29 ARST (webservice:WARN) - docbase unable to locate file system/jndi.xml
2011-02-22 11:54:53 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, 'Rma_ifram/
’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:53 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, ‘Ram_iframe/’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:53 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, 'Rma_ifram/
’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:54:53 ARST (javax.enterprise.resource.webcontainer.jsf.config:WARN) - JSF1057: The resource referred to by from-view-id, ‘Rma_iframe/*’, does not start with ‘/’. This will be added for you, but it should be corrected.
2011-02-22 11:55:55 ARST (com.softwareag.mws.dir.LdapRoleResolver:WARN) [RID:1] - No configuration for: ldapAttributes
2011-02-22 11:55:55 ARST (com.softwareag.mws.dir.LdapRoleResolver:WARN) [RID:1] - No configuration for: ldapAttributes
2011-02-22 11:56:04 ARST (Framework:WARN) [RID:1] - [POP.004.0074] Specified domain in URI not found [domain, uri] – [/directory/workflowactivedirectory/group/meta/default/group/0000010682, workflowactivedirectory]. This can be due to directory service being disabled or removed
directory
2011-02-22 11:56:06 ARST (com.softwareag.mws.dir.LdapRoleResolver:WARN) [RID:1] - No configuration for: ldapAttributes
2011-02-22 11:56:06 ARST (com.softwareag.mws.dir.LdapRoleResolver:WARN) [RID:1] - No configuration for: ldapAttributes
2011-02-22 11:56:06 ARST (com.softwareag.mws.dir.LdapRoleResolver:WARN) [RID:1] - No configuration for: ldapAttributes
2011-02-22 11:56:06 ARST (com.softwareag.mws.dir.LdapRoleResolver:WARN) [RID:1] - No configuration for: ldapAttributes

Hi wmusers,

Even I have the same MWS login problem. Posted _problem logs of MWS server for reference. I could able to see by logs that Error creating database connection. Can anybody let me know how to find out or change the database settings for MWS or how to solve this error as MWS is very important for my work.

Thanks in Advance.

2011-04-18 21:05:26 IST (Framework : FATAL) - Error creating database connection to: jdbc:wm:oracle://localhost:1521;serviceName=wmdb;
java.sql.SQLException: [wm-cjdbc36-0039][Oracle JDBC Driver][Oracle]ORA-01017: invalid username/password; logon denied

at com.wm.dd.jdbc.base.BaseExceptions.createException(Unknown Source)
at com.wm.dd.jdbc.base.BaseExceptions.getException(Unknown Source)
at com.wm.dd.jdbc.oracle.OracleImplConnection.connectAndAuthenticate(Unknown Source)
at com.wm.dd.jdbc.oracle.OracleImplConnection.open(Unknown Source)
at com.wm.dd.jdbc.base.BaseConnection.connect(Unknown Source)
at com.wm.dd.jdbc.base.BaseConnection.setupImplConnection(Unknown Source)
at com.wm.dd.jdbc.base.BaseConnection.open(Unknown Source)
at com.wm.dd.jdbc.base.BaseDriver.connect(Unknown Source)
at java.sql.DriverManager.getConnection(DriverManager.java:525)
at java.sql.DriverManager.getConnection(DriverManager.java:171)
at com.webmethods.portal.service.sql.core.provider.pool.ConnectionPoolManager.create(ConnectionPoolManager.java:102)
at com.webmethods.portal.system.pool.impl.LightweightObjectPool.checkOut(LightweightObjectPool.java:207)
at com.webmethods.portal.service.sql.core.provider.pool.PooledConnectionProvider.getConnection(PooledConnectionProvider.java:168)
at com.webmethods.portal.service.sql.core.BaseSqlWorker.init(BaseSqlWorker.java:106)
at com.webmethods.portal.service.sql.core.ConnectionManager.validateDatasource(ConnectionManager.java:644)
at com.webmethods.portal.service.sql.core.ConnectionManager.init(ConnectionManager.java:270)
at com.webmethods.portal.service.sql.core.ConnectionManager.init(ConnectionManager.java:212)
at com.webmethods.portal.service.sql.core.ConnectionManager.init(ConnectionManager.java:178)
at com.webmethods.portal.system.init.impl.DefaultPhase$InitializableWrapper.init(DefaultPhase.java:118)
at com.webmethods.portal.system.init.impl.DefaultPhase.initComponent(DefaultPhase.java:99)
at com.webmethods.portal.system.impl.BaseProvider.initComponents(BaseProvider.java:509)
at com.webmethods.portal.system.impl.BaseProvider.init(BaseProvider.java:125)
at com.webmethods.portal.system.init.impl.DefaultPhase.init(DefaultPhase.java:44)
at com.webmethods.portal.system.init.impl.DefaultPhaseProvider.initComponent(DefaultPhaseProvider.java:257)
at com.webmethods.portal.system.impl.BaseProvider.initComponents(BaseProvider.java:509)
at com.webmethods.portal.system.impl.BaseProvider.init(BaseProvider.java:125)
at com.webmethods.portal.system.init.impl.DefaultPhaseProvider.initializePhases(DefaultPhaseProvider.java:89)
at com.webmethods.portal.system.PortalSystem.init(PortalSystem.java:867)
at com.webmethods.portal.system.PortalSystem.main(PortalSystem.java:826)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at com.webmethods.portal.system.start.Main.start(Main.java:126)
at com.webmethods.portal.system.start.Main.main(Main.java:47)

2011-04-18 21:05:26 IST (Framework : FATAL) - [POP.004.0202] Cannot create database connection to default MWS datasource. Please verify database connection parameters in the MWS/server/default/config/db.xml configuration file
com.webmethods.portal.system.init.InitializationException: [POP.004.0202] Cannot create database connection to default MWS datasource. Please verify database connection parameters in the MWS/server/default/config/db.xml configuration file
at com.webmethods.portal.service.sql.core.ConnectionManager.validateDatasource(ConnectionManager.java:667)
at com.webmethods.portal.service.sql.core.ConnectionManager.init(ConnectionManager.java:270)
at com.webmethods.portal.service.sql.core.ConnectionManager.init(ConnectionManager.java:212)
at com.webmethods.portal.service.sql.core.ConnectionManager.init(ConnectionManager.java:178)
at com.webmethods.portal.system.init.impl.DefaultPhase$InitializableWrapper.init(DefaultPhase.java:118)
at com.webmethods.portal.system.init.impl.DefaultPhase.initComponent(DefaultPhase.java:99)
at com.webmethods.portal.system.impl.BaseProvider.initComponents(BaseProvider.java:509)
at com.webmethods.portal.system.impl.BaseProvider.init(BaseProvider.java:125)
at com.webmethods.portal.system.init.impl.DefaultPhase.init(DefaultPhase.java:44)
at com.webmethods.portal.system.init.impl.DefaultPhaseProvider.initComponent(DefaultPhaseProvider.java:257)
at com.webmethods.portal.system.impl.BaseProvider.initComponents(BaseProvider.java:509)
at com.webmethods.portal.system.impl.BaseProvider.init(BaseProvider.java:125)
at com.webmethods.portal.system.init.impl.DefaultPhaseProvider.initializePhases(DefaultPhaseProvider.java:89)
at com.webmethods.portal.system.PortalSystem.init(PortalSystem.java:867)
at com.webmethods.portal.system.PortalSystem.main(PortalSystem.java:826)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at com.webmethods.portal.system.start.Main.start(Main.java:126)
at com.webmethods.portal.system.start.Main.main(Main.java:47)

Have you installed the mws properly? Or the log in page disappear suddenly?
The mws database can be setting from IS Admin > Setting > JDBC Pool.
Beside that you may refer to the mws.db.xml located in <webMethods_install_directory>\MWS\server<instance_name>\config

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.