webM 7.1 database configurator error with Oracle 10G XE

Dear techies,

I have a real case, it would be of great help if someone could help me solve it.

I have installed webM 7.1 IS & a Oracle 10G XE edition database. I have not done any configurations in that. I just created a administrator user with full access.

Case:1
While i enable the create tablespace and give the admin password, it says invalid credentials, logon denied, but i am pretty sure that the user name and password is correct and without any special characters. when i remove that option of creating tablespace, it gives me an error saying that WEBMDATA and WEBMINDX or so doesnt exist. so i installed a SQL developer and created those two tablespaces, after that some components got installed or created, and again i am getting error some COMPONENT_ID is missing in some tracking sql file-cannot insert null, so i went to all those files and added a column component_id and a dummy value 1. Now it gives me a variety of new errors.

Does someone know the process to be followed to get it configured and functional ?? if you have some docs, you can also mail it to girish87@gmail.com, i went throught the standard installation doc of webM but could resolve it.

Girish, What exactly you trying to configure?
To configure DB, DB user should have Administrator access.
While installing installer ask for DB details and configure the JDBC pools during installation time. In 7.1 we have DB configurator as well, if you run this it will take care of configuring tables for all components.
I guess this should solve your problem. In case you are looking at some different kind of information, please provide the exact details where you facing the issue or in which step, which tool you are facing the issue.
Thank you

hey mangat, hope ur doing well, regarding the query:
The DB user ofcourse has the administrator access. But still it is not working.

I am using the Database configurator of 7.1 only in which there is an option to check the create tablespace checkbox, i did that but it is not able to create the tablespace saying invalid credential or so. But i am sure its the correct credential. seems little strange but even i am lost of such error.

i have heard many complaints of this problem with oracle 10G XE (ligght edition), any idea ?

Hi, I have installed and reinstalled oracle10g 3 times in the last 6 months on a windows Vista system. I configure via DbConfigurator and start webMethods correctly with configure dbpools and start and view trading networks. However when I restart the computer for some reason all connections and configurations to the database appear to be lost, it has lost all the connections to the database pools in the integration server and cannot even connect to show catalog or print via the configurator. I have posted a question asking for another free database that can be used. I have spent to much time with Oracle10g, please don’t make the same mistake. Life is to short

hi all,

let me try with oracle 9 series and shall let you knw, how it works

Hi All,

Finally after installing the full version of Oracle 10G R2. And a manual configuration for file_create_dest intialization parameter in the database. The Database Component Configurator 7.1 ran successfully.

I created the JDBC pools and associated it, the test was successful again. When i checked the error log, audit log, it was working. But after sometime to my surprise, it gave errors that “Oracle exception,table or view does not exist”

Then i tried to start MWS in cmd mode, it starts so many internal components but after few lines, it says “Invalid Database Schema specified.” I have no clue as all the schemas should ve been created automatically and i dont understand why is it invalid.

Any expertise hands on this pls ??

Since you claimed that DB configuration ran successfully… i m considering it was :wink: … what all the components you configured there…

Please cross check if you have done the above activity for MywebmethodsServer, this is one the database component available to create from DB configuator tool… once it is done… set the DB properties in db.xml file (location : WM installation dir\MWS\server\default\config).
Set the properties depending upon the DB type you have and then try.
revert back… if you still find any issue.

-nD

Hi Dev expert,

I had already tried that even :frowning: But anyways Thanks for your very closest and relevant reply. Infact i had tried to check the config of that file even during installation, i found something suspective there. Thats the reason i did a reconfigure of dbconfigurator for MWS only. After tht it looked better, but still a segment had repeated twice which is still suspective. I have messed it up trying to manually correct it with no use.

May be i think i forgot to drop and create while doing it again for MWS. Let me try that once again and update u with the proceedings.

Thanks,
Girish

Hi, This is the error i get when starting MWS :frowning:

2010-04-20 20:11:36 GMT+05:30 (webm.caf : INFO) - My webMethods Server 7.1.0.0.136
2010-04-20 20:11:36 GMT+05:30 (Framework : INFO) - Loading phase: [phaseID, phaseName] [miePhaseTwo, miePhaseTwo]
2010-04-20 20:11:36 GMT+05:30 (Framework : INFO) - Initializing components of: miePhaseTwo
2010-04-20 20:11:36 GMT+05:30 (Framework : INFO) - Initializing components of: cluster
2010-04-20 20:11:36 GMT+05:30 (Framework : INFO) - Initializing server: master
2010-04-20 20:11:36 GMT+05:30 (Framework : INFO) - Server has roles: [master, taskengine, frontEnd, agentRouting, notification]
2010-04-20 20:11:36 GMT+05:30 (Framework : INFO) - Initializing components of: classManager
2010-04-20 20:12:07 GMT+05:30 (Framework : INFO) - Initializing components of: global
2010-04-20 20:12:08 GMT+05:30 (Framework : INFO) - Initializing components of: languagePackManager
2010-04-20 20:12:09 GMT+05:30 (Framework : INFO) - Loading phase: [phaseID, phaseName] [internalServers, internalServers]
2010-04-20 20:12:09 GMT+05:30 (Framework : INFO) - Initializing components of: internalServers
2010-04-20 20:12:09 GMT+05:30 (Framework : INFO) - Loading phase: [phaseID, phaseName] [DataPhaseOne, DataPhaseOne]
2010-04-20 20:12:09 GMT+05:30 (Framework : INFO) - Initializing components of: DataPhaseOne
2010-04-20 20:12:11 GMT+05:30 (Framework : INFO) - No registered exception delegate
2010-04-20 20:12:11 GMT+05:30 (Framework : FATAL) - [POP.004.0201] Cannot initialize MWS, invalid database schema is specified
com.webmethods.portal.system.init.InitializationException: [POP.004.0201] Cannot initialize MWS, invalid database schema is specified
at com.webmethods.portal.service.sql.core.ConnectionManager.validateDatasource(ConnectionManager.java:621)
at com.webmethods.portal.service.sql.core.ConnectionManager.init(ConnectionManager.java:266)
at com.webmethods.portal.service.sql.core.ConnectionManager.init(ConnectionManager.java:208)
at com.webmethods.portal.service.sql.core.ConnectionManager.init(ConnectionManager.java:174)
at com.webmethods.portal.system.init.impl.DefaultPhase$InitializableWrapper.init(DefaultPhase.java:118)
at com.webmethods.portal.system.init.impl.DefaultPhase.initComponent(DefaultPhase.java:99)
at com.webmethods.portal.system.impl.BaseProvider.initComponents(BaseProvider.java:509)
at com.webmethods.portal.system.impl.BaseProvider.init(BaseProvider.java:125)
at com.webmethods.portal.system.init.impl.DefaultPhase.init(DefaultPhase.java:44)
at com.webmethods.portal.system.init.impl.DefaultPhaseProvider.initComponent(DefaultPhaseProvider.java:257)
at com.webmethods.portal.system.impl.BaseProvider.initComponents(BaseProvider.java:509)
at com.webmethods.portal.system.impl.BaseProvider.init(BaseProvider.java:125)
at com.webmethods.portal.system.init.impl.DefaultPhaseProvider.initializePhases(DefaultPhaseProvider.java:89)
at com.webmethods.portal.system.PortalSystem.init(PortalSystem.java:867)
at com.webmethods.portal.system.PortalSystem.main(PortalSystem.java:826)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at com.webmethods.portal.system.start.Main.start(Main.java:126)
at com.webmethods.portal.system.start.Main.main(Main.java:47)
2010-04-20 20:12:11 GMT+05:30 (Framework : INFO) - Shutting down…
2010-04-20 20:12:11 GMT+05:30 (Framework : INFO) - Shutting down components of: MWS
2010-04-20 20:12:11 GMT+05:30 (Framework : INFO) - Shutting down components of: miePhaseTwo
2010-04-20 20:12:11 GMT+05:30 (Framework : INFO) - Shutting down components of: global
2010-04-20 20:12:11 GMT+05:30 (Framework : INFO) - Shutting down components of: classManager
2010-04-20 20:12:11 GMT+05:30 (Framework : INFO) - Shutting down components of: cluster
2010-04-20 20:12:11 GMT+05:30 (Framework : INFO) - Shutting down components of: miePhaseOne
2010-04-20 20:12:12 GMT+05:30 (Framework : INFO) - Shutdown complete.

Seems that you haven’t configured database parameter in db.xml config file. You need to point this file to the configured database.

You can find this file at installation Dir\MWS\server\default\config

-nD

[SIZE=2]This is the value of the file before and now after reinstalling as well, i have installed oracle 10G R2, connection/db name is “orcl”

<?xml version="1.0" encoding="UTF-8"?> com.webmethods.portal.service.sql.core.BaseSqlWorker com.webmethods.portal.service.sql.core.provider.pool.PooledConnectionProvider com.wm.dd.jdbc.oracle.OracleDriver jdbc:wm:oracle://girish:1521;serviceName=orcl;sysLoginRole=sysdba sys {DES}W48rA0p18tTtd7gLf0JMtw== 100 false SELECT COUNT(*) FROM tblThing WHERE idThing = 1 [/size]

[SIZE=2]

[/size]

hi, sorry for the delay. I had upgraded to a new system with windows 7 64 bit, the IS seems to work fine, but again the same invalild schema issue when i start the MWS. The Database configurator is successfull for all components. Also when i run the tests for JDBC pool that was created automatically with my database is successfull. But in the error log, i see table or view does not exist.

Is there any specific jar files or drivers to be installed for it to function ?

which table does error log in the database normally ?

You only need to put classes12.zip in MWS\lib direcotry.

Try to run the DB configurator with catalog option and see if you can see components installed against MWS.

luck doesnt seem to favour me still :frowning: when i try the catalog i get the following error.

  • Database Connection error: [wm-cjdbc36-0007][Oracle JDBC Driver][Oracle]ORA-28009: connection as SYS should be as SYSDBA or SYSOPER

although i have specified the url as jdbc:wm:oracle://127.0.0.1:1521;SID=xe;sysLoginRole=sysdba

but it is not taking into effect the part sysLoginRole=sysdba, no idea why.

And then, i think my database schema problem is related to the character set encoding, i think for oracle it should be AL32UTF8, and this should correspond to the parameter NLS_LANG but i have only NLS_LANGUAGE parameter which is currently set to AMERICAN and i am struggling to get it changed.

Can u think if something strikes after reading the above updates pls

hi, i was trying with the default SYS user, i now tried with other user and i was able to do a catalog and check the encoding as well.

Catalog result: (seems to be fine for me) ??


  • Executing action
  • Action : catalog
  • Database : Oracle
  • URL : jdbc:wm:oracle://127.0.0.1:1521;SID=xe
  • User : girish


  •  Installed Components      *
    

  • ANL 30 Analysis
  • ARC 20 Archive
  • XRF 10 CrossReference
  • DTP 15 Data Purge
  • DBM 15 Database Management
  • DSL 20 DistributedLocking
  • IDR 10 DocumentHistory
  • ISC 11 ISCoreAudit
  • ISI 20 ISInternal
  • MTR 30 MetadataReasoner
  • MTD 30 MetadataRepository
  • MWS 20 My webMethods Server
  • OPM 15 Operation Management
  • PRA 30 ProcessAudit
  • PRE 30 ProcessEngine
  • PTR 30 ProcessTracker
  • PRP 10 Reporting
  • PST 10 Staging
  • TNS 20 TradingNetworks
  • TNA 20 TradingNetworksArchive

Also it says encoding enabled , but i want to check which encoding is specified ?

Another update is that , i configured a jdbc connection and it got successfully enabled,

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.