MWS 9.0 Migration

I installed MWS 9 and successfully ran Database Component Configarator to migrate MWS component. When I tried to start MWS server I am getting below error.

i - MWS Server Instance was not upgraded yet. Please run ‘MWS/bin/mws.sh (bat) -s <server_name> upgrade’ command first
java.lang.Exception: MWS Server Instance was not upgraded yet. Please run ‘MWS/bin/mws.sh (bat) -s <server_name> upgrade’ command first[/i]

I coulnt find any ‘upgrade’ command which can be used with mws.bat…so I executed /bin/mws.sh (bat) -s <server_name> update command and got below entry.

C:\SoftwareAG\MWS\bin>mws.bat -s default update
JAVA_HOME: C:\SoftwareAG\jvm\jvm170_64
MWS_HOME: C:\SoftwareAG\MWS
WM_HOME: C:\SoftwareAG\MWS…
Buildfile: C:\SoftwareAG\MWS\server\deploy.xml
Successfully updated default server instance. Please see update_default.log for
details and start server instance to complete update.

I verified update_default.log file and everything seems ok. Then I tried to restart MWS in debug mode(mws.bat -d start) but still failing with same error mentioned above…Please advise

You can use below command to upgrade the MWS server instance.

C:\SoftwareAG\MWS\bin>mws.bat -s default upgrade

Make sure that the database on which you ran the migrate scripts is up before running the above command.

Regards,
Sreenivas

Hi Sini,
How did you solve this issue.
Even i am facing it. can you please help me. I could nt find any upgrade command.

Hi Vishal,

Can you confirm whether you installed new MWS instance or migrated existing MWS to new version. In our case, intilally, I didn’t toggle the option for installing new MWS instance while migrating to 9.5 Version. (please refer wM9.5 installation guide - MWS installation)Later I uninstalled the wM9.5 and re-installed and make sure to deselect the option for creating new MWS. After that, run DCC for MWS component and execute migrate.sh script for MWS. Please let me know if this works.

Thanks
Sini

Hi Sini,
I tried both options first i installed with a server instance and then migrated the instance of MWS8.2 to 9.5 . Then I reinstalled without creating an instance of server. I am getting the same error in both cases, that - MWS Server Instance was not upgraded yet. Please run ‘MWS/bin/mws.sh (bat) -s <server_name> upgrade’ command first
, but I do not find any upgrade option for mws.sh script.
So when you reinstalled without creating an instance it worked for you?

If you can give me any more pointers, it would be helpful.

Thanks,
Vishal

Hi Vishal,

Yes, we re-installed without creating an instance , ran the migrate utility and initialized MWS instance before starting MWS.

Can you let me know
1)whether you received any errors during MWS migration.Did you run ./mws.sh –s default init command after MWS migration?
2)Please run dcc with action as catalog and check what is MWS version (We got the version as MWS 40 )
3)Are you getting any errors in <wM9.5 InstallDirectory>\MWS\server\default\logs(_full,problem or erros)
4)In the case of migration , Whether your 8.2 MWS was working fine before

Thanks
Sini

HI Sini,
We ran update manager today and then followed all the steps again starting from DB config. and it worked.
The only strange part is things we did today were done by us earlier also but it didnt work then. Probably some fix would have been required which we got via update manager.
Thanks!! :slight_smile: