Manage TN extended fields through MWS, fields show up and ar

Anyone encountered this problem when working with TN extended (and standard) profile fields?

Trying to view these in MWS, the groups, names and values will show up encoded in base64. Also trying to create new fields the values will be “unencoded” when stored in db making the actual values in database totally unreadable binary gibberish.

Not sure when this problem started however we first noticed some general problems with extended fields after creating some extended fields with default values specified. We have applied all current generally available fixes and service packs regarding IS, TN and MWS but nothing seems to affect this problem. In the database the fields are all looking OK.

Would appreciate any ideas on how to solve or troubleshoot this issue.

I’m not too familiar with the TN User interface, others on this forum might be though… If you don’t get any responses on this forum, you might try cross posting to the B2B forum: “B2B Integration” where i think there would be some TN UI expertise.


Have you tried TN_8.0_SP1_MWS_Fix2?

TNS_8.0_SP1_Fix4 garbled our extended fields - TN_8.0_SP1_MWS_Fix2 was to resolve that.

I have tried the TN_8.0_SP1_MWS_Fix2 without really changing anything. Though I have to agree with mark that the post was misplaced. I have now found that the same results happen in TNC and even the various doQuery services when run from Developer. I’m leaning towards a this being a jdbc-driver issue.

Well the last part turned out to be easily fixed. I noticed that the problems in TNC and developer were related to cache/prefetch and saw that the problem was that we had our Administrator-user disabled and had not changed the “watt.server.cache.prefetchUser” parameter from default.

Once this had been changed to an active user, the problem is back to being only MWS/TN-Extended fields problem. (To make sure I have enabled the Administrator-user in case there is a similar setting somewhere that I am not aware of.)