I can't solve NATURAL dependencies

In Preferences -> Software AG -> Natural -> Project -> Handling of missing objects- We changed this from Ignore to Read from Server.

I have try this configuration unsuccessfully. DDM, Data areas… no resolved.

Please, help

Make sure the properties of the project are pointing to the correct server in the natural configuration (eg a mapped server).

I can post a screenshot up to help if needed.

Also ensure project builds and cleans automatically.

Are there other error messages for the missing reads?

Let me know, thanks.

Thank you Trentan.

Yes, please, post me a screenshot to have an idea.
I usually add a project right clicking on server window in order to have same configuration.
I show you several preferences screenshots to help.

Captura de pantalla 2020-06-15 a las 20.28.04

Sorry for the late reply!

You might want to check “build project automatically”

Also, for the ‘Runtime’ info, where it says ‘use natural server’ you shoiuld be able to select a drop down of a mapped mf server to ensure it is pointing to that one (other wise local).

I would also ensure you clean and build your project (TURN ON A LOG IF YOU CAN TO MAKE SURE IF ANYTHING CLOBBERS YOU HAVE A WAY TO RECOVER - This is especially important if you are not versioning your code (eg Git or Svn).

Finally got around to my blog and plenty more to come, thanks. https://mrnatural.one/

Thank you very much.