Get past the "PDA Init Attention" message when running the F

I enter user admin and password jga/jga, I get the “PDA Init Attention…” message but on clicking OK, I just get returned immediately back to the login screen. Logging in again is not successful


Incidentally, graphics/Icons for the application do notappear at all.

Tamino Server is up. Install.CAB ran succ@ssfully on the PDA. The Jeode rQntime starts OK. I tried uninstAlling and then reinstalling theJeode runtime. amino mobile DBis installed on the PDA. Miniflow.jar is in the /Software AG directory.

An attempt had been made to install the pre-alpha version so everything on the PDA has been removed and reinstalled from scratch.

The console log on the PDA says:

*******accept GET HTTP
Handle request GET HTTP
ConfigFile:getPropertyValue: Property: flow.engine.logsdir not found
24-June-03 launch Tamino Mobile Building Blocks API, version 0.0.1…

The PDA is a Dell Axim running Pocket PC with 64Mb RAM.

Attached are logfiles from the laptop Server and the PDA.

Thanks.


Karnail Jita
Software AG (UK) Ltd

Some days ago I successfully installed alpha FSA on an iPaq, after reinstalling Jeode as I told to remove the error loading SyncProgress.

But now I am trying to run FSA on an old Jornada and I am getting the same results as you.

I think the problem is this message appearing in our flow.log files:

Failed to load image for ‘SyncModel’ java.io.InvalidClassException: com.softwareag.tmb.smartclient.sync.SyncModel; Local class incompatible

I will tell if I find any way to solve it.

Regards

Javier C

At least in my case the problem is the version of the miniflow.jar that is installed in the PDA; it is not the right one. I’ve just copied the one under Studio\tools\codegen\lib and it works.

So you should try the following:
-Stop FSA in the PDA
-Locate your Studio\tools\codegen\lib\miniflow.jar, or take the one included in the ZIP I’ve attached to this message
-Copy it to the /Software AG of your PDA

I do not think the "Failed to load image for ‘SyncModel’ " error is really relevant, but you can also get rid of it by:
-Copying the StartModel.SyncModel.img included in the attached ZIP to the /Software AG/repos/fsa/beanimages folder on your PDA

Hope this helps

Javier C

Strange, I had been told on an earlier note to use the miniflow.jar that comes with the patch rather than the one from the Studio.

Anyway, now that I have tried both including the one you kindly attached, I can confirm that they all have the same unsuccessful behaviour.

Incidentally, the EVMConsole still says “ConfigFile:getPropertyValue: Property: flow.engine.logsdir not found” even before I attempt to logon. Does anyone know what file is being referred to?

Thanks.


Karnail Jita
Software AG (UK) Ltd

Hi,

could you please post us the log files of both attempts with the different miniflow.jar .

And please send us the size in bytes of the two miniflow.jar versions too.

Bye
Thorsten

Hi.

I’ve attached a zip containing the logfiles requested. The miniflow.jar in the directory called ‘patch’ is 399090 bytes, and the one called ‘TMS’ is 394567 bytes. The latter is from the Tamino Mobile Studio directories.

Thanks for your help.


Karnail Jita
Software AG (UK) Ltd

Hi,

The ‘TMS’ version with 394567 bytes is the correct version. My collegue and I had a look on your log files, and it seems to us, that you
have tried to log on without the “New” box checked.

You need to check ‘New’ box the first time you’ll use the application, in order to initialize the mobile database.

Bye
Thorsten

Hi Thorsten.

Thanks, I do logon for the first time with the ‘new’ box checked. Its only when it returns to the logon screen that I repeat the login but without the ‘new’ box checked.

Anyway, I just retried checking ‘new’ each time I logon but still the problem persists I’m afraid.

Cheers.


Karnail Jita
Software AG (UK) Ltd

Hi,

when I have a look on your server log, it shows the 24-Jun-03 as the sync date. Do you have the current alpha version or an earlier version running ?

The server log also shows a the following exception: com.softwareag.tmb.server.da.DataAccessException: Tamino Server is not available. Database with URL 'http://localhost/tamino/tmb

This indicates a Tamino problem. Is your Tamino running on this url? Can you access Tamino with the TII for instance?

Please have look and let me know.

Cheers
Thorsten

Hi Thorsten.

Tamino Server 4.1.4.1 is up, I got a ‘server alive’ message when I tried “http://localhost/tamino/tmb?_diagnose=ping”. Using Tamino X-Plorer I can see data in each Doctype. Is there something I can do or check on the PDA to confirm the connection to Tamino is OK?

Another point worth mentioning is that I get success with “http://KAJ:8080/fsa/app”. But I get a “405 GET not supported” when I try “http://KAJ:8080/fsa_sync/sync”. Not sure if thats relevant so thought I’d mention it.

Thanks.


Karnail Jita
Software AG (UK) Ltd

Hello Karnail!
http://…/fsa_sync/sync is only a non interactive entry point for synchronization. It is only used for synchronization.
We tested our application with Tamino 4112. You are using 4141. Maybe there is a difference. Please
check if you can run with Tamino 4111. Please also try a synchronization with http://193.26.193.72:8080/fsa_sync/sync (internet! Proxy-settings!) or use tamino URL
http://193.26.193.72/tamino/tmb for your server.
Therefore You must modify the tmb(-server).properties files

The access is only allowed for Karnail!!!
regards
Ivo

Hello all,

Please, could someone send me this 394567 bytes miniflow.jar!

Thanks.

Martin

Martin,

The miniflow you requested is attached …


Karnail Jita
Software AG (UK) Ltd

Hello All!

The error message I get is the following:

PDA Init
status: SYNC_LOGIN_FAILED
user: fga

Tamino is up and running: Fetching user_profiles,
customers, etc. within Tamino Interactive Interface works fine!

Any help appreciated!

Regards, Martin :confused:

I forgot to mention …

I use miniflow.jar (399.090 Bytes).
With the other miniflow.jar (394.567 Bytes)
I get immediately redirected to the login form!

Martin

Please have a look to the root dir on the pda.
There should be the log files tmb.log, errout.log and maybe sync.log. Take a look into them and you should find an error message.

If you get SYNC_LOGIN_FAILED the most probable cause is a bad configuration of sync URLs. You have to check this in two points:

a) In the TM Server, you have to configure the fsa_sync repository to reply with the right address of the server.
Open the /repos/fsa_sync/WEB-INF/classes/flow.log file and check the entry “flow.engine.httpapppath” ; the host name there must be the right host name or IP address for the PC at sync time.

If you plan to synchronize only from a PDA that is placed in the cradle (i.e. no LAN, GPRS etc sync, just through the cradle), the best is to put “ppp_peer” as host; it always works.

Reboot the TM server if you change anything in that file.

b) Then you have to check the PDA sync configuration. Copy the file /Software AG/repos/fsa/com/softwareag/tmb/smartclient/tmbSync.properties to the PC, open it and check the “sync_url” entry. Again, the host name there should point to the sync PC.

Again, if you just plan to sync through the cradle, the best option is to use “ppp_peer” as host name; it always work. Otherwise, put the host name or IP address of the PC.


Please note that, with Windows 2000 or XP, if you unplug the laptop from the LAN, then you stop having a valid IP address or host name and so you can NOT sync using it (unless you install the loopback adapter). However, when syncinc through the cradle, ppp_peer is always valid.

Hope this helps

Javier C

Could someone interpret the attached logs and properties.

Thanks in advance!

Martin

isn’t there also a sync.log?

Hallo,

there is the following entry in your sync configuration (tmbSync.properties):

sync_url=http://ppp_peer:8080/fsa_sync/sync

Is “ppp_peer” pointing to your machine with the server part?