Field Service App doesnt start using TMS 1.1.2

Has anyone recompiled the beta FSA using TMS 1.1.2 and successfully run it on a PDA?

This worked successfully using TMS 1.1.1.

Taking the exact same FSA, recompiling and attempting to run this in the browser gives an error “the page you are looking for cannot be found” on Internet Explorer. The EVMConsole says: for %CFG_ENGINE_CHARSET%
at (bytecode 14)
at (bytecode 18)
at (bytecode 21)
******************** done null

Anyone else tried this?

Other TMS-created applications on the PDA seem to work OK, until the FSA is installed.


Karnail Jita
Software AG (UK) Ltd

I have successfully run FSA with TMS 1.1.2 , though I had to modify some things. If you want you can try to run it using the totally unofficial miniflow JAR I am enclosing. Copy it to “\Software AG” in the PDA and rename it as “miniflow.jar”.

Javier C

Thanks Javier, but this didn’t work for me. I suspect the other changes you did are required too.

This is somewhat frustrating as I need TMS 1.1.2 to get around some serious bugs but this version doesn’t work out-of-the-box with the Field Service App. I would have expected this to have been tested before release.

Can someone from development look into this as soon as possible, please.

Karnail Jita
Software AG (UK) Ltd

There will be no tms112 support for FSA beta 1.2!
You can handle tms 111 and 112 in parallel on a notebook for development. For resin you must change the resin_home environment.

Seeing the error you are having, I would check first the file in your PDA. If there is some line looking like


Then edit it and change to


Should this be the case, then probably it is something wrong in your Studio installation.

Javier C

Sorry to play the bad guy here, but I must forbid you to use the modified miniflow.jar from Javier. It is due to a legal aspect.

FSA will be made available for TMS 1.1.2 as part of our regular release schedule. Until officially made available from our download side, We will NOT support TMS 1.1.2 with FSA.

With kind regards
Ralf Rutke