I need some help using FTPs with WM. I am trying to login to a vendors ftp location to fetch some data using FTPs protocol. According to Vendor they are not using any keys or certificates and if I try to login using ssl it does the authentication using session id. I tried using FTP clients with AUTH SSL connection it works but when I use pub.client.ftp:login service with AUTH SSL it doesn’t work. I see “FTP AUTH command failed with error code 530” error. I checked with our admins and they said we do not filter outgoing calls. Any help is appreciated


Try ftp:login with transfertype = passive mode and see how this goes:


Hello RMG, I have tried that with no luck. I still see 530 error code. Do I need to create an FTPs port for outgoing traffic to? If I understood the Admin guide right its only for incoming messages, am I right?. How can I make use of SSL Verisign certificate for outbound ftps calls?

No need for extra ports…did you check with your sys admins and see whats going on in the network layer both sides?

Did you set FTP secure to yes in your login flow when the vendor FTP site is not requesting though?

Thanks RMG. That exactly was the issue. There was a network filter that was stopping the request. I am able to use FTPs now :slight_smile: Appreciate your quick response.