FTPS using pub.cient.ftp is not working

Hi All,

I’m trying to send a file to FTPS server from webMethods 7.1.2 using pub.client:ftp built-in service and it’s throwing the following error.

com.wm.net.ftpCException: [ISC.0064.9001] Could not connect to ftp server: Connection refused (errno:239)

I’m setting the following fields in pub.client:ftp service.

serverhost (IP Address)
serverport (21)
username (username)
password (password)
command (put)
dirpath (client did not give the dir path, we were said that our login privileges will take us the directory where we need to place the files)
transfermode (ascii)
transfertype (passive)
remotefile (test.txt)
content (passing as stream)

  • auth (SSL)

My overall requirement is to put files to an FTPS server using passive mode. I tried using pub.client.ftp:login and pub.client.ftp:put services as well, ‘login’ service works fine, however ‘put’ service fails with the same above error message.

This is really important and I appreciate your help in advance.


I guess for “pub.client.ftp:put” service you need to pass session key as well. which you will get as an output from “pub.client.ftp:login” service.

I’m not really sure, but here’s an idea: could it be that your firewall is blocking the port for the data connection? If you have setup your firewall to allow FTP outbound connections, it may only open ports 21 / 20 (for the control connection and the data connection), but in passive FTP every port >1023 may be used for the data connection on server side, and consequently your firewall needs to allow outbound connections to any of these ports. This would explain, why “login” works ok, but “put” doesn’t.

If you can’t make progress here, you’ll probably have no other chance than making a TCP dump of the connection attempt.


Thanks Lanzelot, You were right, once the outbound ports were open, it worked.



We have a similar requirement to implement FTPS, can you please let us know if any certificate configuration for this was done