Finding default broker monitor

Hi All,
we have some 10 brokers running on our integration environment (one solaris machine) which are installed by different people in different times, suddenly all of them are down. Can any one please let me know how to find the default broker monitor that all the broker servers are connected to. my idea is just to restart the broker monitor and it will start all the broker servers

Thanks in advance

regards
venkat

There is a difference. The awbrokermon is the process that must be running that controls all of the broker servers. Within each broker server you may logical brokers which would be controled by the broker server.

On solaris grep for the process awbrokermon first(S45broker60,61,or 65 is the startup script), is it running? If not you will need to start it first. After you start the awbrokermon process, it will normally startup the broker servers unless you have configured it not to. If you startup the awbrokermon process but no broker servers start then check that your awbrokermon config is correct. The config file on Solaris will normally be in the /var/opt/activesw/awbrokermon.cfg or /var/opt/webmethod/awbrokermon.cfg depending on your version. This config file will tell you where all of the broker servers are installed.

If the configs are correct but still no broker servers and the awbrokermon process is running, check for error logs and core files for each broker server.

hi Venkat
Mark Griffin has already described you the difference between broker servers and broker, I just wanna ask you that are you talking about 10 Broker or Broker server…and as far as your question…

There is no default Broker Monitor because only one broker monitor can run on one machine which takes care of all Broker servers on that machine, so if you start the Broker monitor it would start all the Broker servers on that machine…so any broker under those broker servers should be running fine…

HTH

Talha Khan

Hi,
Thanks for the reply’s. As Griffin mentioned i found the file under /var/opt/activesw/awbrokermon.cfg.

Before this i realised that the brokers are getting automatically started when the m/c starts, so i went to the /etc/rc3.d and found S45broker61. I did a more on the file and got the ACTIVE_CONFIG path which was pointed to the file Griffin metioned.

regards
venkat

So is your problem solved…just curious…

yes… :slight_smile:

I am glad…

Hello All,

I am new to webmethods,I opening a broker server admin page it asks on user name and password,I gave Administrator and manage,Broker and manage,But it cannot be accessed.So if we have any idea for default password for Broker server.please help me.

Thanks&Regards,
Prem Sai