Broker monitor Unable to start Broker instance

Hi ,

We have automatic reboot scheduled for one webmethods server. After the reboot the server started up but the admin console was down. We see the logs in event viewer as shown in attachment.

Our questions are:

  1. What could be the reason for that error?
  2. If broker monitor doesnot start the broker does it effect the admin console to login?

Please suggest.

Hi,

I see that the broker server instance is already running from your attachment.

Share us a detailed error.

If IS is down, please check the server logs and see if you have any error. (Share the error msg)

1> If not try restarting the IS manually.

2> You can also try restarting the broker monitor by stopping the current running instance.

Let me know if you still have issues.

Hi,

I tried restarting the IS manually. Broker is also up. It showed no errors except the error i pasted before.

The console is working with http://hostname:5555 and http://IP:5555

But users are trying to access the admin console through other url as shown in screenshot(http://hkgseaiis:5555)

Note: For other webmethods server the same url is working fine(http://hkgseaiis:5555)

I wanted to know why it is down for this server only when users used this url for admin console in previous times also.

Where to check which url is being used for admin console in IS? What is going wrong here?

EAI error.doc (153 KB)

“Where to check which url is being used for admin console in IS? What is going wrong here?” Can you be provide more detail on this. I did not understand.

i wanted to know what could be the reasons for an admin console to be in down state?

Means if i try with same url in other server its is working fine. Let me show the screenshots .

Strange part is i am not seeing any errors for the console is it is down.

Example.doc (94.5 KB)

Hi Varalakshmi,

From your screenshot, it shows broker is up and you are trying to start up an instance which is already running. Try stopping/killing the process and start again. Broker monitor failure cant affect admin console login.

For the issue when console is not shown for a running server, did you check console is up at http://:5555/WmRoot/? Reasons for console down but process up may also be due to index.dsp in Default package might have been corrupted or deleted. Check that too. One thing which is not clear is how the same URL,port works for 2 different ISs/servers. This seems to be an issue with DNS.

R/V

@NV,

There is a file [hosts] which maps server name with IP. Location: C:\Windows\System32\drivers\etc

Please do

-Check the IE LAN Settings

  • tracert from the machine from which you are unable to reach the server.

HTH.

Thanks,
Rankesh

@Nanduru,

     Try with different browsers and if you are using designer open the Admin page from the designer, use the same URL (copy and Paste) in web browser.

Let me know if u are still not getting.

When the default port is not accessible, you should also try with diagnostic port if you can access the IS Admin page. Default diagnostic port is 9999…

-Senthil

1 Like