FilePolling in mounting folder issue

Hi all,

I need your help.
I’am trying to monitor folder which is mounting from windows share folder in my Linux server .
In my UAT server run well, but not in my production server with the same windows share folder.

I tried to move file file using mv command in prod server, and it’s work. But not using filepolling.
I’ve tried to change log level in to trace level, but there is no detail error found,

thanks in advance

Can you check if the file polling params are correctly set as in UAT. Make sure the input is “ffdata” for your file polling processing service.

1 Like

hi M@he$h ,

Thanks for your reply.
my services and configuration between UAT and prod are same.
I have no input in my file polling processing service.
I got the file using pub.flow:transportInfo document in my service and process the file there,

I tried to monitor internal server folder in my file polling (not mounting folder), and it works well.
Are there any security setting for moving dfile in IS server ?
I’m not sure it caused of my server security. I’ve tried “mv” command and it works.

thank you.

Hi,

Please correct if my understanding about the issue is correct.

I believe you are using internal wM services to move the file in file polling service and its failing but manually using commands you are able to do it.
Please cross verify if you have write Access to the working directory also please provide write access path in fileAccessControl.cnf file in the following path of webmethods server.
C:\SoftwareAG\IntegrationServer\instances[Instance Name]\packages\WmPublic\config\fileAccessControl.cnf[i]

Note: To change the access for a directory you can use “chmod command”
ex: chmod 777 (this will give read, write & Execute access)

Regards,
Syed Faraz Ahmed